Ask Your Question
0

cannot start the neutron-plugin-openvswitch-agent service

asked 2014-11-07 02:30:32 -0600

mehdi gravatar image

I have a problem to start the neutron-plugin-openvswitch-agent service in the "network node". when i run :

service neutron-plugin-openvswitch-agent restart

the output is :

stop: Unknown instance :
neutron-plugin-openvswitch-agent start/running, process 21277

But, if i run :

service neutron-plugin-openvswitch-agent status

the output is :

neutron-plugin-openvswitch-agent stop/waiting

Someone help me please. Thanks

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2014-11-07 10:14:07 -0600

mehdi gravatar image

It's ok now. i have a mistake when i customise the ml12_conf.ini. in the instance_address. it's work now. thank you for help :)


edit flag offensive delete link more

Comments

1

can you please post what was the mistake. I am too facing the same problem.thanks

fresher gravatar imagefresher ( 2014-11-26 07:41:30 -0600 )edit
2

answered 2014-11-07 03:22:22 -0600

dbaxps gravatar image

updated 2014-11-07 10:52:19 -0600

Please,post (as update to question):

    1. /etc/neutron/plugins/ml2/ml2_conf.ini
    2. /var/log/neutron/openvswitch-agent.log
    Output :
    $ neutron agent-list

   Mistake in /etc/neutron/plugins/ml2/ml2_conf.ini fixed
edit flag offensive delete link more
1

answered 2014-11-07 05:58:47 -0600

There can be many reasons for this. Share the logs of the service "openvswitch-agent.log".

edit flag offensive delete link more

Comments

Hi,

I am ended up with the same issue on compute node but unfortunately logs has got generated when i try to restart or start openvswitch-agent

StackLR gravatar imageStackLR ( 2015-05-07 08:45:20 -0600 )edit
0

answered 2015-02-10 03:53:11 -0600

Waid gravatar image

I also has the same problem today. And I totally solve the problem. I will leave here my solution as a reference.

The first very thing to aware of is that we should not leave any space for each line in a configure file of openstack.

For example, the conig. file: ml2_conf.ini when installing the openvswitch on network and compute1 node: if we just uncomment a line like this:

   tenant_network_types = gre

Then we will end up with a problem. And we will find that when we restart a service, soonly we will find it stop after few seconds.

So we should not only uncomment a line, but also remove the space like this:

tenant_network_types

For openvswitch problem like this thread, there's an additional problem that we may found in the log file:/var/log/neutron/openvswitch-agent.log

It is a problem due to the neutron-rootwrap.

So the solution for this could be solved by:

cp -a /usr/lib/python2.7/dist-packages/oslo/rootwarp /usr/local/lib/python2.7/dist-packages/oslo

For the compute1 node, we should mkdir /usr/local/lib/python2.7/dist-packages/oslo before the above cp

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-07 02:30:32 -0600

Seen: 4,944 times

Last updated: Feb 10 '15