Ask Your Question
1

libvert error installing community virtual installation

asked 2014-11-06 16:28:08 -0500

networkguy gravatar image

The following script (for starting the seed VM) fails to execute completely. It terminates with the error message "libvirt.libvirtError: internal error: Unable to determine model for scsi controller".

HP_VM_MODE=y bash -x ~root/tripleo/tripleo-incubator/scripts/hp_ced_host_manager.sh --create seed

I am using the latest download available from the wesite.

root@helion1:~# ls -l total 5839764 -rw------- 1 root root 5979907013 Nov 6 15:16 Helion_Openstack_Community_V1.4.tar.gz drwxrwxr-x 8 1001 1001 4096 Oct 16 09:41 tripleo

/*** last few lines of output before script terminates ********/ Options drive located at /var/lib/libvirt/images/seed_options + configure-vm --name seed --image /var/lib/libvirt/images/seed.qcow2 + --diskbus scsi --baremetal-interface brbm --engine kvm --arch x86_64 + --memory 8388608 --cpus 1 --libvirt-nic-driver virtio --seed libvirt: QEMU Driver error : internal error: Unable to determine model for scsi controller Traceback (most recent call last): File "tripleo/tripleo-incubator/scripts/configure-vm", line 140, in <module> main() File "tripleo/tripleo-incubator/scripts/configure-vm", line 136, in main a = conn.defineXML(libvirt_template) File "/usr/lib/python2.7/dist-packages/libvirt.py", line 3240, in defineXML if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self) libvirt.libvirtError: internal error: Unable to determine model for scsi controller root@helion1:~#

edit retag flag offensive close merge delete

2 answers

Sort by ┬╗ oldest newest most voted
1

answered 2014-11-10 19:24:44 -0500

mrhoades-u gravatar image

i hit the same error. were your ever able to figure out what causes this error, or how to workaround it?

edit flag offensive delete link more

Comments

  1. enable virtualization support in the bios
  2. Install cpu-checker sudo apt-get update sudo apt-get install cpu-checker
  3. checkity check sudo kvm-ok
  4. If enabled you'd get INFO: /dev/kvm exists KVM acceleration can be used
  5. If not enabled you'd get INFO: /dev/kvm does not exist INFO: blah blah
mrhoades-u gravatar imagemrhoades-u ( 2014-11-11 12:59:21 -0500 )edit
0

answered 2014-11-21 12:37:18 -0500

darragh-oreilly gravatar image

I saw this same error with Ubuntu 14.04 and

root@seednode:~# cat tripleo/HP_Helion_Version 
jenkins-installer-build-corvallis-ee-1.0-hlinux-ironic-13: Sun Sep 28 11:43:14 PDT 2014

Changing to Ubuntu 13.10 fixed it.

I heard there was a OpenvSwitch problem with 14.04. This could well be fixed in a more recent Helion version.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-06 16:28:08 -0500

Seen: 523 times

Last updated: Nov 21 '14