Ask Your Question
1

Connecting to existing network with RDO Juno on CentOS 7

asked 2014-11-06 16:00:09 -0500

alex123 gravatar image

updated 2014-11-07 08:23:54 -0500

I need help with network configuration of RDO Juno on CentOS 7 "allinone" single node. My environment is pretty straightforward:

  • one server with one NIC (eno1) connected to 10.4.0.0/16 network
  • clean CentOS 7 minimal install

I performed RDO installation as follows:

  1. followed QuickStart doc and used "packstack --allinone"
  2. followed instructions in "Neutron with existing external network" doc
  3. started an instance of Fedora 19 - as per "Running an instance" doc. I skipped "Step 6 - Associate Floating IP", as the IP assigned to instance already belonged to 10.4.0.0/16 subnet (as result of Step 2)

Unfortunately I'm unable to neither ping nor connect via SSH to my instance (even from the OpenStack node). I'm pretty sure that I followed documents "to the final word" and I did this twice (including clean CentOS reinstall). So it looks like some crucial part is missing in the documents (may be they were not updated for Juno?)

I searched both web and the forums - but couldn't find the answer. Any help will be highly appreciated.


nova secgroup-list-rules default

+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
|             |           |         |           | default      |
+-------------+-----------+---------+-----------+--------------+

sudo ovs-vsctl show

f611f5ff-ad43-434f-9354-d298d4b92bfc
    Bridge br-ex
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port "qg-2ea895e4-13"
            Interface "qg-2ea895e4-13"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port "eno1"
            Interface "eno1"
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        fail_mode: secure
        Port "qr-444e856b-21"
            tag: 2
            Interface "qr-444e856b-21"
                type: internal
        Port "qvoedb986dc-76"
            tag: 5
            Interface "qvoedb986dc-76"
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.1.3"

ifconfig

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.4.219.50  netmask 255.255.0.0  broadcast 10.4.255.255
        inet6 fe80::8861:51ff:fe85:4147  prefixlen 64  scopeid 0x20<link>
        inet6 4040:30::42a8:f0ff:fe23:86ec  prefixlen 64  scopeid 0x0<global>
        ether 40:a8:f0:23:86:ec  txqueuelen 0  (Ethernet)
        RX packets 1698280  bytes 642208685 (612.4 MiB)
        RX errors 0  dropped 264  overruns 0  frame 0
        TX packets 181413  bytes 19611925 (18.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-int: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::c4b6:e0ff:fef6:d646  prefixlen 64  scopeid 0x20<link>
        ether c6:b6:e0:f6:d6:46  txqueuelen 0  (Ethernet)
        RX packets 110  bytes 13680 (13.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::42a8:f0ff:fe23:86ec  prefixlen 64  scopeid 0x20<link>
        ether 40:a8:f0:23:86:ec  txqueuelen 1000  (Ethernet)
        RX packets 1743448  bytes 652400973 (622 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Please,run on AIO node :
$ nova secgroup-list-rules default
$ ovs-vsctl show
$ ifconfig
$ route -n

dbaxps gravatar imagedbaxps ( 2014-11-06 23:35:33 -0500 )edit

Thanks for the help. I added this information to my question.

alex123 gravatar imagealex123 ( 2014-11-07 08:17:02 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-09 10:14:38 -0500

alex123 gravatar image

I figured this out.

Turns out default Neutron configuration created by RDO is completely botched - private subnet and router and not visible by Horizon and have some dummy IP addresses defined on them that made no sense in my environment.

So I had to completely delete and re-create it via the following commands:

neutron router-gateway-clear router1
neutron subnet-delete public_subnet
neutron net-delete public
neutron router-interface-delete router1 private_subnet
neutron subnet-delete private_subnet
neutron net-delete private
neutron router-delete router1

neutron router-create router1
neutron net-create private
neutron subnet-create --name private_subnet private 192.168.100.0/24 --allocation-pool start=192.168.100.224,end=192.168.100.254
neutron router-interface-add router1 private_subnet

neutron net-create public --router:external=True
neutron subnet-create public 10.4.0.0/16 --name public_subnet --enable_dhcp=False --allocation-pool start=10.4.219.224,end=10.4.219.254 --gateway=10.4.0.1
neutron router-gateway-set router1 public

This solves the problem.

edit flag offensive delete link more
0

answered 2014-11-07 09:29:29 -0500

dbaxps gravatar image

updated 2014-11-07 09:38:47 -0500

My configuration under /etc/sysconfig/network-scripts :-

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="192.168.1.127"
NETMASK="255.255.255.0"
DNS1="83.221.202.254"
BROADCAST="192.168.1.255"
GATEWAY="192.168.1.1"
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"  <===== New in Juno
OVS_BRIDGE=br-ex <===== New in Juno
DEVICETYPE="ovs"

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-enp2s0
DEVICE="enp2s0"
# HWADDR=00:22:15:63:E4:E2
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no

# chkconfig network on
# service network restart 

# systemctl disable NetworkManager
# systemctl  stop NetworkManager

By default ML2&OVS&VXLAN should be set up by packstack --allinone
On my 2 Node Cluster

[root@juno1 ~(keystone_admin)]# ovs-vsctl show
f2113bd0-c4ca-4c4b-af16-928ff03e53da
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "vxlan-c0a80089"
            Interface "vxlan-c0a80089"
                type: vxlan
                options: {df_default="true", in_key=flow, local_ip="192.168.0.127", out_key=flow, remote_ip="192.168.0.137"}
    Bridge br-int
        fail_mode: secure
        Port "tap3f570ba8-a1"
            tag: 2
            Interface "tap3f570ba8-a1"
                type: internal
        Port "tapb593041a-c7"
            tag: 4095
            Interface "tapb593041a-c7"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port "qr-17ddee14-9f"
            tag: 1
            Interface "qr-17ddee14-9f"
                type: internal
        Port "tap7a12f9b0-a4"
            tag: 1
            Interface "tap7a12f9b0-a4"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port "qr-5bbf9169-4b"
            tag: 3
            Interface "qr-5bbf9169-4b"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-940b2f09-e9"
            tag: 2
            Interface "qr-940b2f09-e9"
                type: internal
    Bridge br-ex
        Port "qg-fd2baf63-9e"
            Interface "qg-fd2baf63-9e"
                type: internal
        Port "enp2s0"
            Interface "enp2s0"
        Port "qg-7b037650-10"
            Interface "qg-7b037650-10"
                type: internal
        Port "qg-bb0b3d86-75"
            Interface "qg-bb0b3d86-75"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    ovs_version: "2.1.3"

Make sure SELINUX=permissive
Check your /etc/neutron/plugin.ini as soft link to

[root@juno1 ~(keystone_admin)]# cat /etc/neutron/plugins/ml2/ml2_conf.ini | grep -v ^# | grep -v ^$
[ml2]
type_drivers = vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =1001:2000
vxlan_group =239.1.1.2
[securitygroup]
enable_security_group = True

Attention OVS bridge br-int should not show up in output of ifconfig . My sample :-

[root@juno1 ~(keystone_admin)]# ifconfig
br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.127  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::222:15ff:fe63:e4e2  prefixlen 64  scopeid 0x20<link>
        ether 00:22:15:63:e4:e2  txqueuelen 0  (Ethernet)
        RX packets 637128  bytes 810883641 (773.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 380611  bytes 116830773 (111.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::222:15ff:fe63:e4e2  prefixlen 64  scopeid 0x20<link>
        ether 00:22:15:63:e4:e2  txqueuelen 1000  (Ethernet)
        RX packets 753854  bytes 972611049 (927.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 438214  bytes 120912516 (115.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device ...
(more)
edit flag offensive delete link more
0

answered 2015-06-29 08:58:57 -0500

alohamora gravatar image

Hello @alex123

Thanks for posting answer to your own question , is helpful for me.

Could you please post your /etc/neutron/plugins/ml2/ml2_conf.ini and packstack answerfile ( if your setup still exists )

What kind of network did you used , is it FLAT , VLAN or VXLAN ?

Would really appreciate your answer.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-11-06 15:56:27 -0500

Seen: 5,486 times

Last updated: Jun 29 '15