Ask Your Question

neutron agent-list not showing on controller node

asked 2014-11-06 08:23:01 -0500

federic0 gravatar image

hi dears, i've not found a suitable answer in the askOS DB, i'm installing my OpenStack lab at home following the official guides, 3 nodes, and i'm stuck here on chapter six ( where on the controller node i should see the "neutron agent-list" with l3,dhcp,metadata agents registered. i don't see anything, the command gives no output. rabbitMQ connection is fine, logs are not showing errors or connection refused messages, NTP is in sync across the nodes. i would like to have some ideas where to start investigation. thanks.

edit retag flag offensive close merge delete


service neutron-server status
service neutron-l3-agent status
service neutron-dhcp-agent
and so on .....

dbaxps gravatar imagedbaxps ( 2014-11-06 23:41:36 -0500 )edit

[root@fdr_01_ntwk ~]# systemctl is-active neutron-openvswitch-agent.service neutron-l3-agent.service neutron-dhcp-agent.service neutron-metadata-agent.service neutron-ovs-cleanup.service active active active active active

all of them (but the cleanup) are in the active(running) status

federic0 gravatar imagefederic0 ( 2014-11-07 02:06:56 -0500 )edit

4 answers

Sort by ยป oldest newest most voted

answered 2014-11-07 00:00:29 -0500

vthapar gravatar image

Check the logs for each of the agents on network node. One common mistake I've seen is starting a separate rabbitmq on network node and point agents to that. So, check neutron.conf on Network Node and make sure it is pointing to your controller node [assuming that is where your rabbitmq is running].

edit flag offensive delete link more


thanks, but rabbit_host is pointing at the controller node where rabbitMQ is running. ain't easy to troubleshoot because there are many interactions involved and at this point i can't understand exactly what each OS component does, i also got a AMPQ .pcap file but i don't know what the protocol does

federic0 gravatar imagefederic0 ( 2014-11-07 02:12:47 -0500 )edit

answered 2014-11-19 06:06:38 -0500

samfrid gravatar image

updated 2014-11-19 06:08:41 -0500

You are not supposed to disable iptables rules, you have to update iptables rules to open port 5672.

# netstat -lnpt | grep 5672

to make sure rabbitmq-server Openstack AMQP broker is listening at this port

edit flag offensive delete link more


thanks for your suggestin, but i need to understand where/who/why the iptables rules are done in this way, i can't find firewalld service, so there should be some other way to add those rules. after that i can modify them accordingly. thanks.

federic0 gravatar imagefederic0 ( 2014-11-19 14:11:54 -0500 )edit
dbaxps gravatar imagedbaxps ( 2014-11-21 08:06:34 -0500 )edit

answered 2015-03-16 04:47:33 -0500

sbiswas7 gravatar image

This could be due to a timing missmatch between your controller and your compute node as well. If they are operating in different offsets, then neutron server may reject the registration of the agent. Make sure that the times on both your neutron server and your compute node are in sync.

edit flag offensive delete link more


Thanks! It was helpful!

KarthikV gravatar imageKarthikV ( 2016-03-08 00:41:28 -0500 )edit

answered 2014-11-18 15:06:41 -0500

federic0 gravatar image

same as for compute node (where nova-compute wasn't starting because of iptables rules on the controller node blocking amqp communication) disabling iptables rules on the controller node made the neutron node able to connect with the messaging server (rabbit). i need to better understand where/how/from/when/why those iptables rules are defined in the controller node. please provide any suggestion. thanks

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-11-06 08:21:46 -0500

Seen: 3,577 times

Last updated: Nov 19 '14