Ask Your Question

Heats webhook respond 'incomplete-signature'-error (not conform to AWS standards)

asked 2014-11-05 23:20:37 -0500

mc__ gravatar image

updated 2014-11-09 20:50:11 -0500

Hi there,

as I wanted to check out the autoscaling features of heat in combination with ceilometer, I tried to adapt one of the example HOT's. Meanwhile, the HOT is starting successfully, but whatever I do to stress my VM in the web_server_group, no scaling reaction is observable.
Executing the webhook manually, there's an error response, which google hardly knows, so I try my best here - maybe you can help me to solve this problem.
Additionally I'm wondering, why AWS is mentioned in the error - actually I don't want to use it. Are webhooks only possible via AWS?

Core Issue:

 curl -XPOST -i
[1] 7073
[2] 7074
[3] 7075
[4] 7076
root@foo:/home/bar# HTTP/1.1 400 IncompleteSignature
Content-Type: application/xml; charset=UTF-8
Content-Length: 171
Date: Thu, 06 Nov 2014 03:11:55 GMT

<ErrorResponse><Error><Message>The request signature does not conform to AWS standards</Message><Code>IncompleteSignature</Code><Type>Sender</Type></Error></ErrorResponse>

Another try:

curl -X POST
[3]   Done                    SignatureMethod=HmacSHA256
[4]   Done                    AWSAccessKeyId=e4f6cefc18a34695b1aba1bd5e0bbb0a
[5]   Done                    SignatureVersion=2
user@vm-foo:~$ <ErrorResponse><Error><Message>The request signature does not conform to AWS standards</Message><Code>IncompleteSignature</Code><Type>Sender</Type></Error></ErrorResponse>

Further specs:
Version OpenStack Icehouse VM: Ubuntu 14.04
stress command: 'stress --cpu 8 --io 8 --vm 2 --vm-bytes 256M &' causing permanent usage of ~60% CPU usage. On the host, heat-api-cfn is running, and port 8000 is in use.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2014-11-06 02:47:24 -0500

shardy gravatar image

Hi, please can you try the following:

curl -XPOST -i ""

If you don't quote the URL, then the & character before the first query-string argument backgrounds the curl and fails to pass the arguments via the request

edit flag offensive delete link more

answered 2014-11-06 03:33:06 -0500

mc__ gravatar image

updated 2014-11-06 03:34:27 -0500

Ok thanks, better. Now the error turns to

HTTP/1.1 403 AccessDenied
Content-Type: application/xml; charset=UTF-8
Content-Length: 149
Date: Thu, 06 Nov 2014 09:30:00 GMT

<ErrorResponse><Error><Message>User is not authorized to perform action</Message><Code>AccessDenied</Code><Type>Sender</Type></Error></ErrorResponse>

/var/log/heat/heat-api-cfn.log and /var/log/heat/heat-api-cloudwatch.log is empty,

But /var/log/heat/heat-engine.log returns repetitious

 2014-11-06 16:51:26.327 2086 WARNING heat.common.keystoneclient [req-d3f4ebed-f380-422e-93a3-c995f4fb2427 None] stack_user_domain ID not set in heat.conf falling back to using default

Should I split the question and open a new one?

edit flag offensive delete link more


See for the resolution to this problem

shardy gravatar imageshardy ( 2014-11-10 05:50:15 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-11-05 23:20:37 -0500

Seen: 2,094 times

Last updated: Nov 09 '14