Ask Your Question
0

Does keystone_manage db_sync succeed with python-sqlalchemy 0.9.x?

asked 2014-11-04 20:21:50 -0500

t.goto gravatar image

Hello,

I've been testing OpenStack Icehouse on CentOS7 these days, and I'm stuck when I keystone_manage db_sync. a Warning message follows.

stderr: /usr/lib/python2.7/site-packages/migrate/changeset/databases/mysql.py:37: SADeprecationWarning: Use ``<obj>.name.quote``
  old_col_name = self.preparer.quote(delta.current_name, table.quote)
/usr/lib/python2.7/site-packages/migrate/changeset/databases/mysql.py:37: SADeprecationWarning: Use ``<obj>.name.quote``
  old_col_name = self.preparer.quote(delta.current_name, table.quote)
/usr/lib/python2.7/site-packages/migrate/changeset/databases/mysql.py:37: SADeprecationWarning: Use ``<obj>.name.quote``
  old_col_name = self.preparer.quote(delta.current_name, table.quote)
/usr/lib/python2.7/site-packages/migrate/changeset/ansisql.py:278: SADeprecationWarning: Use ``<obj>.name.quote``
  return self.preparer.quote(ret, cons.quote)

I found out using python-sqlalchemy-0.8.4 instead of python-sqlalchemy-0.9.7-3.el7 prevents this warning and I can successfully install and use stack.

Is this just me? Or are you somehow excluding python-sqlalchemy-0.9.7-3.el7 from being installed?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-11-10 03:10:17 -0500

NikStSG gravatar image

You need to first install the packet "yum-plugin-priorities"

server# yum -y install yum-plugin-priorities

This way yum will choose python-sqlalchemy-0.8.4 from ICEHOUSE repo, and not version 0.9.7, which is a part of EPEL repo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-04 20:21:50 -0500

Seen: 226 times

Last updated: Nov 04 '14