Ask Your Question
2

AMQP server is unreachable: [Errno 104] Connection reset by peer

asked 2014-11-04 08:46:06 -0500

bkopilov gravatar image

Hi , Working with RHEL7 with RHOS 5 version . Storage backend : Del equallogic.

In the cinder log message we hit on : Nov 3 15:07:33 test5413 cinder-volume: 2014-11-03 15:07:33.284 28431 WARNING cinder.openstack.common.loopingcall [-] task run outlasted interval by 6.842228 sec Nov 3 15:07:33 test5413 cinder-volume: 2014-11-03 15:07:33.285 28431 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on 10.35.167.67:5672 is unreachable: [Errno 104] Connection reset by peer. Trying again in 7 seconds.

Question : #1 How can we change retry counter , Trying again in 7 seconds , i would like to set it to 1 . #2 How can we increase tcp handshake values, can we do it from rabitmq configuration file ?

Thanks , Benny

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-11-04 09:15:32 -0500

dbaxps gravatar image

updated 2015-01-07 21:09:14 -0500

smaffulli gravatar image

Restart RabbitMQ service: sudo service rabbitmq-server restart. If it won't work check iptables:

$ iptables-save | grep 5672

and make sure port is open via iptables firewall. Then check

$ service rabbitmq-server  status

[root@juno1 ~(keystone_admin)]# netstat -lntp | grep 5672
tcp6       0      0 :::5672                 :::*                    LISTEN      2941/beam.smp       

[root@juno1 ~(keystone_admin)]# ps -ef | grep 2941

should look something like:

rabbitmq  2941     1  0 16:32 ?        00:00:35 /usr/lib64/erlang/erts-5.10.4/bin/beam.smp -W w -K true -A30 -P 1048576 -- -root /usr/lib64/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../ebin -noshell -noinput -s rabbit boot -sname rabbit@juno1 -boot start_sasl -config /etc/rabbitmq/rabbitmq -kernel inet_default_connect_options [{nodelay,true}] -rabbit tcp_listeners [{"auto",5672}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@juno1.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@juno1-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@juno1-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@juno1"
edit flag offensive delete link more
0

answered 2015-01-07 20:15:09 -0500

Suheng gravatar image

updated 2015-01-07 20:15:49 -0500

I find a way to solve this problem:

  1. for i in ps aux|grep rabbit|awk '{print $2}';do kill -9 $i;done

  2. rabbitmqctl add_user openstack_rabbit_user openstack_rabbit_password; rabbitmqctl set_permissions -p / openstack_rabbit_user "." "." ".*" ; rabbitmqctl set_user_tags openstack_rabbit_user administrator;

  3. restart the rabbitmq

Suheng in cecgw

edit flag offensive delete link more

Comments

so this is a user permission issue? are you use the default user 'guest' in your rabbit? could you share us how you find the solution?Thanks!

9lives gravatar image9lives ( 2015-01-07 20:37:04 -0500 )edit

yeah,it's 'guest'...I try a lot ways and find it.

Suheng gravatar imageSuheng ( 2015-01-07 21:00:55 -0500 )edit

ok, we met this issue many time, restart might resolve it in most of the time, however the best practice is add new rabbit user and use new vhost with permissions and you just prove it.:-)

9lives gravatar image9lives ( 2015-01-07 21:12:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-11-04 08:46:06 -0500

Seen: 11,593 times

Last updated: Jan 07 '15