Ask Your Question
2

Unable to configure Neutron DB in Juno

asked 2014-11-03 13:44:48 -0500

baldo gravatar image

Hello.

I'm carefully following the OpenStack Juno installation manual, and I'm stuck in this step: http://docs.openstack.org/juno/install-guide/install/apt/content/neutron-controller-node.html (http://docs.openstack.org/juno/instal...)

First, and I guess this is a bug, when I execute the neutron-db-manage command, I'm getting the next error:

> Class router cannot be found

I can easily fix that, by writing the class name rather than the entry point name, i.e.: neutron.services.l3_router.l3_router_plugin.L3RouterPlugin instead of router.

Fine, this is solved. But when executing the command again I get the next output:

> No handlers could be found for logger "neutron.common.legacy" INFO 
> [alembic.migration] Context impl MySQLImpl. INFO  [alembic.migration]
> Will assume non-transactional DDL.  
> No such revision 'juno'

And I'm stuck here, I don't know how to proceed. I've been looking for people with similar problems but I cannot find anything similar.

Thanks

edit retag flag offensive close merge delete

Comments

I'm stuck at the same point here, any pointers, Baldo did you manage to fix this ?

Garysday gravatar imageGarysday ( 2014-11-26 14:04:32 -0500 )edit

What database and version are you using? (e.g. MariaDB 5.5)

SamYaple gravatar imageSamYaple ( 2014-11-26 19:19:28 -0500 )edit

Hi, it is MariaDB 5.5.40.

baldo gravatar imagebaldo ( 2014-11-27 01:30:23 -0500 )edit

Ok baldo. MariaDB10 has issues with neutron commands. MariaDB5.5 works correctly.

SamYaple gravatar imageSamYaple ( 2014-11-27 11:37:12 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2014-11-26 15:28:35 -0500

Garysday gravatar image

Baldo,

In order to get his working try the following

instead of su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron

Use this instead…

su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade head" neutron

head is the latest trunk, this works for me .. you can go into the mysql database and see the tables populated.

edit flag offensive delete link more

Comments

It seems to work, but the last line of the command output states:

INFO [alembic.migration] Running upgrade 5ac1c354a051-> icehouse, icehouse

So it does not seem to be Juno version of Neutron, does it?

baldo gravatar imagebaldo ( 2014-11-27 01:35:53 -0500 )edit

Do not use head. You definitely want to use juno (unless you are just testing things).

Please verify you package versions. Are you sure you are running with juno packages (2014.2)?

SamYaple gravatar imageSamYaple ( 2014-11-27 11:38:36 -0500 )edit

We follow the official installation guide released at Jan 20 and met the same issue. Any workaround? Thanks.

jamesxu gravatar imagejamesxu ( 2015-01-25 00:09:27 -0500 )edit

For me your work around doesn't fix the problem I tried it and got the same error: No handlers could be found for logger "neutron.common.legacy"..

PCQ gravatar imagePCQ ( 2015-02-02 10:36:04 -0500 )edit

Oh, I see now, the package can't be finde: ImportError: Class ml2 cannot be found. For your work around I had to edit the file nano /etc/neutron/neutron.conf again:

PCQ gravatar imagePCQ ( 2015-02-02 10:40:43 -0500 )edit
0

answered 2015-02-02 10:31:18 -0500

PCQ gravatar image

I also follow the openStack Juni installation guide and get the same error at this part. Is there any solution?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-11-03 13:44:48 -0500

Seen: 7,703 times

Last updated: Feb 02 '15