swift post %containername% = 404 Not Found

asked 2014-11-03 05:02:28 -0500

SimbioS gravatar image

updated 2014-11-03 06:08:36 -0500

Hi All. I setaped OS storage (swift) for testing. So i used 5 virtual servers openVZ for storege nodes. One server (physical) installed proxy server + keystone.

Authorization is OK:

curl -d '{"auth":{"passwordCredentials":{"username": "ross", "password": "mypass"},"tenantName":"ross"}}' -H "Content-type: application/json" http://localhost:5000/v2.0/tokens | python -mjson.tool

Mount drive is OK:

curl -i http://192.168.0.1:6000/recon/diskusage - and other node [{"device": "ploop12277p1", "avail": 9858093056, "mounted": true, "used": 708726784, "size": 10566819840
 swift-recon -l -d 

Starting reconnaissance on 5 hosts Disk usage: space used: 3543633920 of 52834099200 Disk usage: space free: 49290465280 of 52834099200 Disk usage: lowest: 6.71%, highest: 6.71%, avg: 6.70709631404%

But i want to create the new container like name "VPS":

swift post VPS Container PUT failed:http://1.1.1.2:5000:5000/v2.0/VPS 404 Not Found [first 60 chars of response] {"error": {"message": "The resource could not be found.", "c

Please help me to resolve this trouble. And more, how i can connect to my storage cluster via "CloudBerry Explorer for OpenStack Storage" ? http://1.1.1.2:5000 - keystone ? or http://1.1.1.2:8080 - swift proxy ? If you need any more just said me.

Many thanks.

edit retag flag offensive close merge delete

Comments

Hi all. I confusion. I still have not solved this problem. Any help. Thanks.

SimbioS gravatar imageSimbioS ( 2014-11-13 05:07:34 -0500 )edit