Ask Your Question
1

cinder-volume not showing in service list

asked 2014-11-02 03:44:45 -0500

gparaskevas gravatar image

updated 2014-11-03 02:03:53 -0500

RHK gravatar image

Hello, i just installed the first cinder node(on an existing compute node, only metadata running) and i cant get it listed in the cinder service list. When i create a volume its in error state. Can you please help me alittle? I must be missing something here. Thanks

ALSO: Here are some logs after i try to create a volume. I know i cant create a volume if dot have cinder-volume. Also, cinder-volume service is running on the node

Controller- cinder-api

2014-11-02 16:01:55.197 4016 INFO oslo.messaging._drivers.impl_rabbit [req-fe712ba1-67e8-49f6-908a-cd2f50e16857 d10647f55b82489eacf1bbba085ff4f9 76a99cc67174466abecc012484740b85 - - -] Connected to AMQP server on 192.168.1.10:5672

Controler-cinder-scheduler Failed to run task cinder.scheduler.flows.create_volume.ScheduleCreateVolumeTask;volume:create: No valid host was found. No weighed hosts available

node1-cinder-volume nothing here

edit retag flag offensive close merge delete

Comments

I had the same errors in cinder-volume.log file until in cinder.conf I moved 3 string from oslo_messaging_rabbit section to DEFAULT section. Understand? These three strings: rabbit_host = controller rabbit_userid = openstack rabbit_password = password i moved from [oslo_messaging_rabbit] to [DEFAULT

Ramirezkiv gravatar imageRamirezkiv ( 2016-01-21 05:44:38 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-03 12:11:51 -0500

gparaskevas gravatar image

updated 2015-01-03 09:09:33 -0500

I ffound the solution after taling directly on IRC. By default the debconf didnt create the database conection string in the cinder.conf and also the database cinder user couldnt coonect from anything alse than local host. after manualy creating the connection string in Cinder.conf and also putting % in the Cinder-common DB user Cinder volume was registered in the database. I dont know if this should be filed as a bug of the Guide

edit flag offensive delete link more

Comments

Hi, there! I met a same porblem of yours with a same log. Can U describe the concrete operations of this solution, please! Thanks !

NeilFeng gravatar imageNeilFeng ( 2015-01-05 01:22:55 -0500 )edit

HI I'm facing the same problem any help !! thanks

ebtihel gravatar imageebtihel ( 2017-04-11 10:11:31 -0500 )edit
1

answered 2014-11-02 07:32:11 -0500

Check if the cinder-volume service is able to connect to AMQP server. And also ensure that all the nodes in openstack setup are synchronized(w.r.t time).

edit flag offensive delete link more

Comments

yes i can see it is "2014-11-02 13:19:46.731 3724 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on 192.168.1.10:5672"

As fpr the time NTP is running on all nodes and the controller. Also the nodes are also ruunig compute whose services are runnnig with no errors.

gparaskevas gravatar imagegparaskevas ( 2014-11-02 08:00:27 -0500 )edit
0

answered 2014-11-03 02:02:39 -0500

RHK gravatar image

Hi,

post the configuration of below files.

/etc/cinder/cinder.conf
/etc/cinder/api-paste.ini
/etc/tgt/conf.d/cinder_tgt.conf
/etc/tgt/tagets.conf

and give the out put of:

ps -ef |grep tgtd
tgtadm --lld iscsi --op show --mode system

verify the cinder services are running,

cd /etc/init.d/; for i in $( ls cinder-* ); do sudo service $i status; done

Regards,
RHK

edit flag offensive delete link more

Comments

@RHK I have done what you said and i have also posted above all the logs and confs. CInder is running on controller and on node. I have weird problem with tgtd i cannot restart it, i may not have init.d scripts but i can see it on services list. Thank you!

gparaskevas gravatar imagegparaskevas ( 2014-11-03 06:15:26 -0500 )edit

@RHK anything? Please... I just redid everything and still the same issue.

gparaskevas gravatar imagegparaskevas ( 2014-11-08 04:11:57 -0500 )edit
0

answered 2016-04-21 15:02:44 -0500

thoken gravatar image

Hi I have no cinder-volume in the cinder service -list. My cinder-scheduler is up. Can some1 help me pls?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-11-02 03:44:45 -0500

Seen: 3,205 times

Last updated: Jan 03 '15