Network configuration on network node

asked 2014-10-31 04:00:21 -0600

D20K gravatar image

updated 2014-11-01 01:48:51 -0600

Hi, in a new installation of ICEhouse on Window8.1 Host and VMware Ubuntu 14.04LTS VMS - 3 node configuration at the point, network node external interface eth2 doesn't work well.

I configure management network with VMware NAT and external network with VMware Bridge like below.

image description

eth0 in all node works well but Network node's eth2 doesn't works.

even I disconnect eth0, eth2 cannot communicate with gw 192.168.0.1

Controller node

root@controller:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0c:29:fc:33:d6
      inet addr:10.0.0.11  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::20c:29ff:fefc:33d6/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:608622 errors:0 dropped:0 overruns:0 frame:0
      TX packets:454149 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:166276135 (166.2 MB)  TX bytes:130771362 (130.7 MB)

lo        Link encap:Local Loopback
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:2015193 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2015193 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:667960155 (667.9 MB)  TX bytes:667960155 (667.9 MB)

root@controller:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.0.0.2        0.0.0.0         UG    0      0        0 eth0
10.0.0.0        *               255.255.255.0   U     1      0        0 eth0

root@controller:~# ping -c 3 network
PING network (10.0.0.21) 56(84) bytes of data.
64 bytes from network (10.0.0.21): icmp_seq=1 ttl=64 time=0.399 ms
64 bytes from network (10.0.0.21): icmp_seq=2 ttl=64 time=1.22 ms
64 bytes from network (10.0.0.21): icmp_seq=3 ttl=64 time=0.983 ms

--- network ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 0.399/0.869/1.225/0.346 ms

root@controller:~# ping -c 3 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_seq=1 ttl=128 time=0.210 ms
64 bytes from 10.0.0.2: icmp_seq=2 ttl=128 time=0.167 ms
64 bytes from 10.0.0.2: icmp_seq=3 ttl=128 time=0.204 ms

--- 10.0.0.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.167/0.193/0.210/0.024 ms

root@controller:~# ping -c 3 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=128 time=2.95 ms
64 ...
(more)
edit retag flag offensive close merge delete

Comments

Please, post ovs-vsctl show && ifconfig on network node.
Is VMWare NAT able to create second internal network 10.0.1.0/24 ? ? If answer is "YES"
I believe that way out is to place br-ex on 10.0.1.0/24 and make eth2 OVS port of OVS bridge br-ex.

dbaxps gravatar imagedbaxps ( 2014-10-31 07:45:48 -0600 )edit

The simplest solution is not using eth2 at all . Place br-ex on 10.0.0.0/24 and make eth0 OVS port of OVS bridge br-ex.

dbaxps gravatar imagedbaxps ( 2014-10-31 07:48:01 -0600 )edit

@dbaxps internal 10.0.1.0/24 network is instance tunnel with VMWare Host Only. I just update my question added ovs-vsctl show ( click more)

D20K gravatar imageD20K ( 2014-11-01 01:48:10 -0600 )edit

@dbaxps I want to configure controller node connect to network's external ip (192.168.0.21) because when instance launched it cannot connect to metadata server

D20K gravatar imageD20K ( 2014-11-01 02:07:07 -0600 )edit

Please, add Compute node to your picture. Consider as sample https://www.hastexo.com/system/files/... page 20

dbaxps gravatar imagedbaxps ( 2014-11-01 05:42:17 -0600 )edit