Ask Your Question
0

neutron-server is not running

asked 2014-10-30 14:47:37 -0500

shailendra gravatar image

updated 2015-02-16 00:16:28 -0500

Moe gravatar image

hello folks plz help me in resolving issues.

till yesterday everything was working fine but i don't know why today neutron-server is not running.

i'm trying to start neutron-server but it doesn't get start. and also my dashboard is showing error "something went wrong". i m confused. i can understand it might because neutron-server is not working but how to start neutron? service neutron-server start not working :(

edit retag flag offensive close merge delete

Comments

What says /var/log/neutron/server.log ?

dbaxps gravatar imagedbaxps ( 2014-10-30 14:54:37 -0500 )edit
shailendra gravatar imageshailendra ( 2014-10-30 15:11:35 -0500 )edit

Try checking if there are any space issues on the machine in which neutron-server is running? And also try deleting neutron-server.log, restart netron-server service and check if there are any error messeges in the log.

sushma-korati gravatar imagesushma-korati ( 2014-10-31 00:45:30 -0500 )edit

service neutron-server start/restart not working neutron-server is stopped msg is showing when it is checked after these cmds

shailendra gravatar imageshailendra ( 2014-10-31 01:23:36 -0500 )edit

but when i manually run by cmd neutron-server on terminal it works. but unfortunately it is not working after manual run :(

shailendra gravatar imageshailendra ( 2014-10-31 01:25:02 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-16 00:25:33 -0500

Moe gravatar image

try:

tail -f /var/log/neutron/*.log

then at the same time in another tty or screen try service neutron-server restart also leave

netstat -ntlp
ls -al /etc/neutron/
la -al /var/log/neutron/

check if the file/folder owners are right?

also try login with su neutron and run the neutron-server command manually this ill lead to some solutions :)

edit flag offensive delete link more
0

answered 2015-02-16 05:31:41 -0500

Praveen N gravatar image

Check the status of rabbit-mq server and selinux policy.You can give a try by first setting selinux policy to be disabled, then restart rabbit-mq server.If rabbit-mq is active and running then ensure there is an IP assigned with the eth interface for your system node.Then restart openstack services/neutron server. After which if there is need in your env, you can work by changing the selinux to permissive policy and repeat this procedure.Hope this helps...:)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-30 14:47:37 -0500

Seen: 3,736 times

Last updated: Feb 16 '15