Ask Your Question
1

Neutron's br-ex interface disappear at reboot

asked 2013-09-20 03:41:04 -0600

gvdm gravatar image

Hi to all,

I've a Devstack+Neutron Ubuntu 12.04 machine. The Neutron installation added the "br-ex" interface to my Ubuntu machine and gave it the IP 172.24.4.225

The problem is that when I reboot the DevStack machine the br-ex disappears from the available interfaces shown with the "ifconfig" command. What should I do?

Thank you Giulio

edit retag flag offensive close merge delete

Comments

you just need to run stack.sh and everthing should be recreated.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-20 08:22:59 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-20 07:59:49 -0600

OldParrothead gravatar image

updated 2013-09-20 08:02:09 -0600

There are a few items you can do to "save" this configuration. I have done both and they both work.

FIRST ITEM - Make sure of proper configuration in /etc/network/interfaces. Otherwise, it will never work properly. Ethernet card should have NO IP address, and bridge should have IP address assigned to it.

1st - This I did prior to installing OpenVSwitch while machines were still in build mode. Simple add the appropriate brctl addbr and brctl addif to /etc/rc.local and things will come alive after startup. brctl addbr br-xx brctl addif br-xx ethx

2nd - Did this AFTER OpenVSwitch was installed. Add the bridges and ports using ovs-vsctl statements and they stay after reboot ovs-vsctl add-bridge br-xx ovs-vsctl add-port br-xx ethx

Tom Catyb Twingles Consulting

edit flag offensive delete link more
0

answered 2013-10-23 21:50:32 -0600

dasp gravatar image

updated 2013-10-23 21:51:03 -0600

A good idea is to bring br-ex up together with the interface it's bound to. For example, I use eth2 for br-ex exclusively and this is my /etc/network/interface file:

# Public interface for br-ex
allow-hotplug eth2
auto eth2
iface eth2 inet manual
    up ip addr add 0.0.0.0 dev eth2
    up ip link set eth2 promisc on
    up ip link set eth2 up
    up route add default gw 192.168.0.1 dev eth2
    up ip link set br-ex up # This is the line you are interested in

It might be enough for you to add the last line to the appropriate interface in your /etc/network/interfaces.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-20 03:41:04 -0600

Seen: 2,595 times

Last updated: Oct 23 '13