devstack does not start when enabling neutron

asked 2013-09-19 20:24:06 -0600

hackman gravatar image

I am getting this error:

2013-09-19 18:07:45 + /usr/local/bin/neutron-db-manage --config-file /etc/neutron/neutron.conf --con
fig-file /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini upgrade head
2013-09-19 18:07:45 Traceback (most recent call last):
2013-09-19 18:07:45   File "/usr/local/bin/neutron-db-manage", line 6, in <module>
2013-09-19 18:07:45     from neutron.db.migration.cli import main
2013-09-19 18:07:45 ImportError: No module named neutron.db.migration.cli

My localrc is:

DATABASE_PASSWORD=<password>
RABBIT_PASSWORD=<password>
SERVICE_TOKEN=<some token>
SERVICE_PASSWORD=<password>
ADMIN_PASSWORD=<password>
HOST_IP=192.168.210.204
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
ENABLED_SERVICES=q-meta,q-lbaas,n-obj,n-cpu,n-sch,n-cauth,horizon,mysql,rabbit,cinder,c-api,c-vol,c-sc
h,n-cond,q-svc,q-agt,q-dhcp,q-l3,n-novnc,n-xvnc,q-lbaas,g-api,g-reg,key,n-api,n-crt
LOGFILE=$DEST/logs/stack.log
# SCREEN_LOGDIR=/opt/stack/logs
CINDER_BRANCH=stable/grizzly
GLANCE_BRANCH=stable/grizzly
HORIZON_BRANCH=stable/grizzly
KEYSTONE_BRANCH=stable/grizzly
NOVA_BRANCH=stable/grizzly
NEUTRON_BRANCH=stable/grizzly
SWIFT_BRANCH=stable/grizzly
SERVICE_TOKEN=devstack
SCHEDULER=nova.scheduler.chance.ChanceScheduler
enable_service swift
SWIFT_HASH=devstack
edit retag flag offensive close merge delete

Comments

Hi, looks like DevStack missed out on installing that module, could you post the entire output ie your $DEST/logs/stack.log file here. Since there's quite a bit of text in there, you could paste the text at paste.openstack.org and post the corresponding link here.

Sirushti Murugesan gravatar imageSirushti Murugesan ( 2013-09-20 09:27:52 -0600 )edit

Is your DevStack repository pointing to stable/grizzly? Also, if you made any changes to the code, DevStack won't update your repository, thus leading to not checking out to the desired branch.

Sirushti Murugesan gravatar imageSirushti Murugesan ( 2013-09-21 16:37:40 -0600 )edit

Yep, That's right. Glad you got it to work :) Could you convert the above response to an answer so that the other people facing the same issue will know the solution. Thanks

Sirushti Murugesan gravatar imageSirushti Murugesan ( 2013-10-12 01:14:15 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-21 16:19:49 -0600

hackman gravatar image

After going through the execution of stack.sh in debug, I understand a lot more about its operation. I should not have set the 'ENABLED_SERVICES' variable. Instead, modify the default that is specified in stackrc by invoking enable_service or disable_service appropriately. After doing that, I ran into the problem that was posted on stackoverflow: http://stackoverflow.com/questions/17681226/cloudfoundry-grizzly-keystone-with-devstack-install-configparser-error-in-keyst/18937657#18937657 I have posted an answer there as user2802945. My question is why should my repositories point to 'master' when 'stable/grizzly' should have worked. Is there anything else that needs to be done.

edit flag offensive delete link more
0

answered 2013-10-11 19:25:16 -0600

hackman gravatar image

I have been busy with other things, but the main problem was my localrc was pointing to stable/grizzly while the main devstack repository - the devstack.git was pointing to master. after doing 'git clone git://github.com/openstack-dev/devstack.git', I should have checked out origin/stable/grizzly for devstack.git if I really wanted to experiment with that branch. I simply removed the 'xxx_BRANCH' lines above and let the defaults in stackrc take effect (ie. master branch), and now everything works.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-19 20:24:06 -0600

Seen: 2,492 times

Last updated: Sep 19 '13