Ask Your Question
0

Can't ping external network from router or instances [closed]

asked 2014-10-30 04:10:20 -0600

Jorge Florencio gravatar image

Hello, i´m running OpenStack Juno release on CentOS 7.0 with three networks:

  • Private Network: 192.168.10.128/27 (for gre tunnel)
  • External Network: 192.168.10.160/27 (for management & external access)
  • VM Netwok: 192.168.10.192/27 (for instances)

Here is the bridge configuration:

# ovs-vsctl show
30e10303-8042-4eab-921e-e07b7de4657f
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-c0a80a8e"
            Interface "gre-c0a80a8e"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.10.141", out_key=flow, remote_ip="192.168.10.142"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        fail_mode: secure
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port "tap8ab8fa25-08"
            tag: 1
            Interface "tap8ab8fa25-08"
                type: internal
        Port "qr-11a3dee8-a4"
            tag: 1
            Interface "qr-11a3dee8-a4"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-ex
        Port "qg-21faed98-74"
            Interface "qg-21faed98-74"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port "ens224"
            Interface "ens224"
    ovs_version: "2.1.3"

The IPs of qrouter:

# ip netns exec qrouter-394aece6-82e3-4f25-b44d-7592c7833493 ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
14: qr-11a3dee8-a4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:bc:b4:17 brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.193/27 brd 192.168.10.223 scope global qr-11a3dee8-a4
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:febc:b417/64 scope link
       valid_lft forever preferred_lft forever
15: qg-21faed98-74: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:9a:8a:a7 brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.164/27 brd 192.168.10.191 scope global qg-21faed98-74
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe9a:8aa7/64 scope link
       valid_lft forever preferred_lft forever

I can ping a instance:

# ip netns exec qrouter-394aece6-82e3-4f25-b44d-7592c7833493 ping -c 4 192.168.10.196
PING 192.168.10.196 (192.168.10.196) 56(84) bytes of data.
64 bytes from 192.168.10.196: icmp_seq=1 ttl=64 time=0.926 ms
64 bytes from 192.168.10.196: icmp_seq=2 ttl=64 time=0.531 ms
64 bytes from 192.168.10.196: icmp_seq=3 ttl=64 time=0.499 ms
64 bytes from 192.168.10.196: icmp_seq=4 ttl=64 time=0.439 ms

--- 192.168.10.196 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3000ms
rtt min/avg/max/mdev = 0.439/0.598/0.926/0.194 ms

But I can´t ping external gateway:

# ip netns exec qrouter-394aece6-82e3-4f25-b44d-7592c7833493 ping -c 4 192.168.10.161
PING 192.168.10.161 (192.168.10.161) 56(84) bytes of data.

--- 192.168.10.161 ping statistics ---
4 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Jorge Florencio
close date 2014-11-08 18:06:24.172826

1 answer

Sort by » oldest newest most voted
2

answered 2014-11-08 18:05:40 -0600

Jorge Florencio gravatar image

The issue has been solved.

This installation is over a ESXi server (nested virtualization) and promiscuous mode must be enabled on vSwitch configuration.

edit flag offensive delete link more

Comments

thanks you for your answere.

Tung Nguyen gravatar imageTung Nguyen ( 2014-12-13 13:26:48 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-30 04:10:20 -0600

Seen: 1,310 times

Last updated: Nov 08 '14