Ask Your Question
2

juno installation error on Cent 7

asked 2014-10-30 04:32:08 -0600

yoshi5409 gravatar image

updated 2014-10-30 12:39:22 -0600

rbowen gravatar image

Hello I want to install openstack on CentOS 7 right after I read the RDO Quick Start Guide . but i haven't install openstack yet . anyone who knows the way to solve the matter Please let me know

redhat-release
CentOS Linux release 7.0.1406 (Core)

uname -a
Linux allinone 3.10.0-123.el7.x86_64 #1 SMP Mon Jun 30 12:09:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

##this is the way I tried to install openstack on CentOS##
yum update -y

yum install -y https://rdo.fedorapeople.org/rdo-release.rpm

yum install -y openstack-packstack

packstack --allinstall

[I found this error message]

XXX.XXXX.XXXX_provision_demo.pp:                  [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: xxx.xxx.xxx.xxx_provision_demo.pp
Error: Could not prefetch neutron_network provider 'neutron': Execution of '/usr/bin/neutron net-list --format=csv --column=id --quote=none' returned 1: Unauthorized (HTTP 401) (Request-ID: req-efc09383-708c-427c-ba7c-27d84b0701ee)
You will find full trace in log /var/tmp/packstack/20141030-154435-lYuwji/manifests/xxx.xxx.xxx.xxx_provision_demo.pp.log
Please check log file /var/tmp/packstack/20141030-154435-lYuwji/openstack-setup.log for more information

##openstack-setup.log ##

014-10-30 15:45:12::INFO::shell::81::root:: [localhost] Executing script:
cd /usr/lib/python2.7/site-packages/packstack/puppet
cd /var/tmp/packstack/20141030-154435-lYuwji/manifests
tar --dereference -cpzf - ../manifests | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@xxx.xxx.xxx.xxx tar -C /var/tmp/packstack/cc71b5aaf8b94c1bb4689f7886b622ba -xpzf -
cd /usr/share/openstack-puppet/modules
tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qpid rabbitmq remote rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd openstacklib | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@xxx.xxx.xxx.xxx tar -C /var/tmp/packstack/cc71b5aaf8b94c1bb4689f7886b622ba/modules -xpzf -
2014-10-30 15:50:33::ERROR::run_setup::921::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 902, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 688, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 718, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: xxx.xxx.xxx.xxx_provision_demo.pp
Error: Could not prefetch neutron_network provider 'neutron': Execution of '/usr/bin/neutron net-list --format=csv --column=id --quote=none' returned 1: Unauthorized (HTTP 401) (Request-ID: req-efc09383-708c-427c-ba7c-27d84b0701ee)
You will find full trace in log /var/tmp/packstack/20141030-154435-lYuwji/manifests/xxx.xxx.xx ...
(more)
edit retag flag offensive close merge delete

Comments

I presume you mean --allinone rather than --allinstall?

Also, did you reboot after yum -y update ?

rbowen gravatar imagerbowen ( 2014-10-30 12:47:36 -0600 )edit

Hi rbwoen

I followed this document https://openstack.redhat.com/Quickstart

Document says "packstack --allinone" so i did so

and I have already updated the system

yoshi5409 gravatar imageyoshi5409 ( 2014-10-30 23:52:21 -0600 )edit

I've just updated the system therefore I got an other problem from openstack .

Applying Puppet manifests [ ERROR ] ERROR : Error appeared during Puppet run: xxx.xxx.xxx.xxx_keystone.pp

Now Horizon doesn't work , Should I remove openstack before i install again ?

yoshi5409 gravatar imageyoshi5409 ( 2014-10-31 04:02:50 -0600 )edit

I tried to excute "packstack --allinone" again .

therfore I solved this matter

I could see this messages

* Installation completed successfully ***

I've no idea what causes ware

yoshi5409 gravatar imageyoshi5409 ( 2014-10-31 04:24:29 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-10-31 04:28:23 -0600

yoshi5409 gravatar image

updated 2014-10-31 04:32:04 -0600

You should update CentOS until you can see this messages

yum update -y

Loading mirror speeds from cached hostfile

  • base: ftp.iij.ad.jp

  • epel: mirrors.vinahost.vn

  • extras: http://mirrors.btte.net

  • updates: http://mirrors.btte.net

No packages marked for update

and then we shuold excute "packstack --allinone" several times

edit flag offensive delete link more
0

answered 2014-11-25 04:26:45 -0600

If you have run packstack previously, there will be a file in your home directory named something like packstack-answers-20130722-153728.txt You will probably want to use that file again, using the --answer-file option, so that any passwords you've already set (eg, mysql) will be reused.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-10-30 02:04:59 -0600

Seen: 5,111 times

Last updated: Nov 25 '14