Ask Your Question
1

Juno Authentication to Horizon error - too many connections

asked 2014-10-28 08:31:21 -0500

azriel gravatar image

Hi,

I'm using Juno on ubuntu 14.04 and I'm not able to log in anymore via the dashboard. I'm getting errors like "An error occurred authenticating. Please try again later." " not able to authenticate with any project"

keystone-all.log

2014-10-28 15:24:35.833 3358 ERROR keystone.common.wsgi [-] (OperationalError) (1040, 'Too many connections') None None
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi Traceback (most recent call last):
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/common/wsgi.py", line 223, in __call__
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     result = method(context, **params)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/token/controllers.py", line 100, in authenticate
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     context, auth)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/token/controllers.py", line 287, in _authenticate_local
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     username, CONF.identity.default_domain_id)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/identity/core.py", line 202, in wrapper
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     return f(self, *args, **kwargs)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/identity/core.py", line 213, in wrapper
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     return f(self, *args, **kwargs)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/identity/core.py", line 600, in get_user_by_name
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     ref = driver.get_user_by_name(user_name, domain_id)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/identity/backends/sql.py", line 146, in get_user_by_name
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     session = sql.get_session()
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/common/sql/core.py", line 192, in get_session
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     return _get_engine_facade().get_session(expire_on_commit=expire_on_commit)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/common/sql/core.py", line 176, in _get_engine_facade
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     _engine_facade = db_session.EngineFacade.from_config(CONF)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/oslo/db/sqlalchemy/session.py", line 795, in from_config
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     retry_interval=conf.database.retry_interval)
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/oslo/db/sqlalchemy/session.py", line 711, in __init__
2014-10-28 15:24:35.833 3358 TRACE keystone.common.wsgi     **engine_kwargs)
2014-10-28 15:24 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-10-28 09:23:20 -0500

jpichon gravatar image

It looks like you may want to increase the mysql configuration value for max_connections?

edit flag offensive delete link more

Comments

10x, that seems to solve the issue.

azriel gravatar imageazriel ( 2014-10-29 02:56:36 -0500 )edit
1

I have the same problem. It seems like the connections are never closed. I use Juno / MariaDB.

Sebastian gravatar imageSebastian ( 2014-11-05 09:50:05 -0500 )edit
2

Same problem here, but the number of connections just keeps growing until hitting whichever max_connections limit. The issue rather seems to be connections never being closed.

Michael Steffens gravatar imageMichael Steffens ( 2014-11-05 10:02:29 -0500 )edit

set the max_connection value under /etc/mysql/my.cnf

azriel gravatar imageazriel ( 2014-11-19 10:19:27 -0500 )edit
1

I'm adding this as much for google searches as anything. OpenStack dashboard slow performance, this setting fixed that toot sweet.

scoday gravatar imagescoday ( 2015-03-05 18:07:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-28 08:31:21 -0500

Seen: 2,451 times

Last updated: Oct 28 '14