Ask Your Question
1

qpid settings for grizzly - Cinder/Nova [closed]

asked 2013-09-19 05:16:41 -0500

ArKam gravatar image

updated 2014-01-22 15:12:39 -0500

Evgeny gravatar image

Hi fellows!

I'm currently running a lab test OS Grizzly within two nodes, one for the Cloud controller, and one for the compute node.

Now, I'm trying to use qpid as AMQP/RPC Server, but it seems that I'm missing some point because the cinder volume and cinder scheduler services aren't able to connect to it.

Here is the error message:

Sep 19 10:53:19 CLUNODE02 cinder-volume[26858]: 2013-09-19 10:53:19    ERROR [cinder.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 1 seconds
Sep 19 10:53:20 CLUNODE02 cinder-volume[26858]: 2013-09-19 10:53:20    ERROR [cinder.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 2 seconds
Sep 19 10:53:22 CLUNODE02 cinder-volume[26858]: 2013-09-19 10:53:22    ERROR [cinder.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 4 seconds
Sep 19 10:53:26 CLUNODE02 cinder-volume[26858]: 2013-09-19 10:53:26    ERROR [cinder.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 8 seconds
Sep 19 10:53:34 CLUNODE02 cinder-volume[26858]: 2013-09-19 10:53:34    ERROR [cinder.openstack.common.rpc.impl_qpid] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 16 seconds

Here is my cinder config:

[DEFAULT]
auth_strategy = keystone
logdir = /var/log/cinder
state_path = /var/lib/cinder
lock_path = /var/lib/cinder/tmp
volumes_dir = /home/cinder/volumes
volume_group = cinder-volumes
volume_name_template = volume-%s
iscsi_helper = tgtadm
sql_connection = mysql://cinder:cinder@CLUNODE01/cinder
rpc_backend = cinder.openstack.common.rpc.impl_qpid
qpid_hostname=CLUNODE02
qpid_port=5672
rootwrap_config = /etc/cinder/rootwrap.conf
api_paste_config = /etc/cinder/api-paste.ini

[keystone_authtoken]
admin_tenant_name = service
admin_user = cinder
admin_password = secret
auth_host = CLUNODE01
auth_port = 35357
auth_protocol = http
signing_dirname = /tmp/keystone-signing-cinder

I didn't set the username and password because my qpid server doesn't seems to have one on default run.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 21:09:01.197024

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-09-19 07:10:33 -0500

ArKam gravatar image

I confirm, Firewall is disable and not running anymore, my qpidd service is running and listening on 5672 port (found the information on logs) and of course the host is able to resolve given host correctly.

Indeed, I just check my conf and space between parameter and = is needed and the same between = and hostname. So, problem solved :D

edit flag offensive delete link more

Comments

To be honest that seems like a pretty poor user experience to me, I would consider filing a bug in Launchpad.

sgordon gravatar imagesgordon ( 2013-09-19 08:12:39 -0500 )edit

Many thanks for your help. I'm not sure that this issue really require a bug report on launchpad, honestly, it's mostly a user attention problem I think. I have not been enough focus on what I wrote. This is a lack of documentation steps and explanation I think. Nova/Cinder chapter is quite messy

ArKam gravatar imageArKam ( 2013-09-19 08:43:35 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-19 05:16:41 -0500

Seen: 793 times

Last updated: Sep 19 '13