Ask Your Question
0

[Resolved]No output packets from OVS

asked 2014-10-27 11:35:55 -0500

kodokuu gravatar image

updated 2014-10-28 10:21:40 -0500

Hi,

i use RDO Icehouse (last version) on Centos 6.4. My compute use a vcenter hypervisor for VM. I use neutron in VLAN mode.

My problem is that no packets coming from my network interface (ETH1). DHCP listen all traffic from his vlan but when it send a packets (e.g ARP REQUEST), the packet stop on physical interface.

EDIT : When i create a interface vlan with vconfig on br-int doesn't works. But if I create on ETH1 it works.

OVS-SHOW

Bridge "br-eth1"
    Port "phy-br-eth1"
        Interface "phy-br-eth1"
    Port "eth1"
        Interface "eth1"
    Port "br-eth1"
        Interface "br-eth1"
            type: internal
Bridge br-int
    fail_mode: secure
    Port "qr-88d37ebf-94"
        tag: 1
        Interface "qr-88d37ebf-94"
            type: internal
    Port int-br-ex
        Interface int-br-ex
    Port "tapdfabaa84-81"
        tag: 1
        Interface "tapdfabaa84-81"
            type: internal
    Port "tap69934b76-96"
        tag: 2
        Interface "tap69934b76-96"
            type: internal
    Port br-int
        Interface br-int
            type: internal
    Port "int-br-eth1"
        Interface "int-br-eth1"
Bridge br-ex
    Port "eth0"
        Interface "eth0"
    Port br-ex
        Interface br-ex
            type: internal
    Port phy-br-ex
        Interface phy-br-ex
ovs_version: "1.11.0"

IP NETNS

qrouter-18fd5cf3-6a3d-414e-bc50-4d90594302a0
qdhcp-40565ab9-52f4-4d5a-b0a1-d301b1fd41ca
qdhcp-f8348d9c-74d4-4941-aabd-a0574cef6f7f
qrouter-2b0f0543-c1e0-4e88-a152-66c70b3da4ed

IFCONFIG qdhcp-f8348d9c-74d4-4941-aabd-a0574cef6f7f

tapdfabaa84-81 Link encap:Ethernet  HWaddr FA:16:3E:87:3C:7C
          inet addr:10.122.143.191  Bcast:10.122.143.255  Mask:255.255.255.0
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:5662 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:363689 (355.1 KiB)  TX bytes:756 (756.0 b)

qdhcp-f8348d9c-74d4-4941-aabd-a0574cef6f7f PING GATEWAY

From 10.122.143.191 icmp_seq=2 Destination Host Unreachable
From 10.122.143.191 icmp_seq=3 Destination Host Unreachable

TCPDUMP (vlan 1961) on ETH1

17:29:22.439937 fa:16:3e:87:3c:7c > Broadcast, ethertype 802.1Q (0x8100), length 46: vlan 1961, p 0, ethertype ARP, Request who-has 10.122.143.3 tell 10.122.143.191, length 28

DUMP FLOW br-eth1

NXST_FLOW reply (xid=0x4):
 cookie=0x0, duration=2931.248s, table=0, n_packets=31, n_bytes=1326, idle_age=78, priority=4,in_port=2,dl_vlan=1 actions=mod_vlan_vid:1961,NORMAL
 cookie=0x0, duration=2930.835s, table=0, n_packets=12, n_bytes=512, idle_age=1841, priority=4,in_port=2,dl_vlan=2 actions=mod_vlan_vid:1963,NORMAL
 cookie=0x0, duration=2990.365s, table=0, n_packets=2, n_bytes=84, idle_age=2928, priority=2,in_port=2 actions=drop
 cookie=0x0, duration=2990.954s, table=0, n_packets=29468, n_bytes=2141003, idle_age=0, priority=1 actions=NORMAL

DUMP FLOW br-int

NXST_FLOW reply (xid=0x4):
 cookie=0x0, duration=2966.27s, table=0, n_packets=7329, n_bytes=514267, idle_age=0, priority=3,in_port=2,dl_vlan=1963 actions=mod_vlan_vid:2,NORMAL
 cookie=0x0, duration=2966.684s, table=0, n_packets=6210, n_bytes=423514, idle_age=0, priority=3,in_port=2,dl_vlan=1961 actions=mod_vlan_vid:1,NORMAL
 cookie=0x0, duration=3026.722s, table=0, n_packets=15829, n_bytes=1123000, idle_age=0, priority=2,in_port=1 actions=drop
 cookie=0x0, duration=3025.908s, table=0, n_packets=16079, n_bytes=1202782, idle_age=0, priority=2,in_port=2 actions=drop
 cookie=0x0, duration=3028.729s, table=0, n_packets=45, n_bytes=1890, idle_age=113, priority=1 ...
(more)
edit retag flag offensive close merge delete

Comments

You didn't create any neutron router. ip netns doesn't show any qrouter-namespace.
There is no qg-xxxxxxxxx interface attached to br-ex.

dbaxps gravatar imagedbaxps ( 2014-10-27 12:47:12 -0500 )edit

I remove qrouter from ip netns for best read.

ip netns

qrouter-18fd5cf3-6a3d-414e-bc50-4d90594302a0
qdhcp-40565ab9-52f4-4d5a-b0a1-d301b1fd41ca
qdhcp-f8348d9c-74d4-4941-aabd-a0574cef6f7f
qrouter-2b0f0543-c1e0-4e88-a152-66c70b3da4ed
kodokuu gravatar imagekodokuu ( 2014-10-28 03:14:01 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-10-28 05:43:13 -0500

kodokuu gravatar image

Solution :

ovs-vsctl set interface eth1 other-config:enable-vlan-splinters=true

edit flag offensive delete link more
0

answered 2014-10-27 13:28:06 -0500

dbaxps gravatar image

updated 2014-10-27 13:32:18 -0500

Forced to use answer field due to formatting option :-

[root@icehouse1 ~(keystone_admin)]# ip netns
qdhcp-c07c3957-b87b-4891-81a1-4119f354a922
qdhcp-12c74482-e12a-46e9-8353-f813026a5ae7
qdhcp-b6e4a53c-bc1f-4751-93e9-70c6775dd186
qrouter-ef95717c-1525-4750-9b57-20c5196275ac
qrouter-87ee4cb5-9e61-436a-9f50-eb8a064ba8a0
qrouter-d2526168-b52f-43fd-a73a-5b76a2b416db

See qg-interfaces in corresponding qrouter-namespace

   [root@icehouse1 ~(keystone_admin)]# ip netns exec qrouter-ef95717c-1525-4750-9b57-20c5196275ac ifconfig
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 0  (Local Loopback)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    qg-3a153315-4b: flags=67<UP,BROADCAST,RUNNING>  mtu 1500
            inet 192.168.1.153  netmask 255.255.255.0  broadcast 192.168.1.255
            inet6 fe80::f816:3eff:fe0e:923  prefixlen 64  scopeid 0x20<link>
            ether fa:16:3e:0e:09:23  txqueuelen 0  (Ethernet)
            RX packets 468  bytes 73270 (71.5 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 23  bytes 1362 (1.3 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    qr-2adc87c6-e3: flags=67<UP,BROADCAST,RUNNING>  mtu 1500
            inet 40.0.0.1  netmask 255.255.255.0  broadcast 40.0.0.255
            inet6 fe80::f816:3eff:fe7b:d49d  prefixlen 64  scopeid 0x20<link>
            ether fa:16:3e:7b:d4:9d  txqueuelen 0  (Ethernet)
            RX packets 22  bytes 2184 (2.1 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 17  bytes 1298 (1.2 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    [root@icehouse1 ~(keystone_admin)]# ip netns exec qrouter-ef95717c-1525-4750-9b57-20c5196275ac route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 qg-3a153315-4b
    40.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 qr-2adc87c6-e3
    192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 qg-3a153315-4b

Then view how qg-interface comes up in ovs-vsctl show

[root@icehouse1 ~(keystone_admin)]# ovs-vsctl show
fcafcc72-ae2b-473c-8cec-28b475be6c0a
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "vxlan-c0a80089"
            Interface "vxlan-c0a80089"
                type: vxlan
                options: {in_key=flow, local_ip="192.168.0.127", out_key=flow, remote_ip="192.168.0.137"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port "qg-c3d3dd33-7d"
            Interface "qg-c3d3dd33-7d"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-3a153315-4b"
            Interface "qg-3a153315-4b"
                type: internal
        Port "enp2s0"
            Interface "enp2s0"
        Port "qg-f1cf97d0-d3"
            Interface "qg-f1cf97d0-d3"
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
    Bridge br-int
        fail_mode: secure
        Port "tapbb523d41-60"
            tag: 1
            Interface "tapbb523d41-60"
                type: internal
        Port "qr-860c5219-d9"
            tag: 2
            Interface "qr-860c5219-d9"
                type: internal
        Port int-br-ex
            Interface int-br-ex
        Port "tapd4084a38-0c"
            tag: 2
            Interface "tapd4084a38-0c"
                type: internal
        Port "qr-1599cece-7e"
            tag: 1
            Interface "qr-1599cece-7e"
                type: internal
        Port "tap5f4da521-3f"
            tag: 3
            Interface "tap5f4da521-3f"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port "qr-2adc87c6-e3"
            tag: 3
            Interface "qr-2adc87c6-e3"
                type: internal
    ovs_version: "2.0.0"
edit flag offensive delete link more

Comments

Thx for your help. As you can see, my TAP from DHCP is in br-int in ovs-vsctl show.

DHCP==>TAP==>BR-INT==>INT-BR-ETH1==>PHY-BR-ETH1==>BR-ETH1==>ETH1 |||| STOP

And I try to ping gateway from my qRouter and doesn't work too. My eth1 block all packets. I tried to change MTU.

kodokuu gravatar imagekodokuu ( 2014-10-28 03:19:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-27 11:35:55 -0500

Seen: 1,380 times

Last updated: Oct 28 '14