Ask Your Question
0

auth.py error in tempest run

asked 2014-10-27 04:09:26 -0500

rsiva gravatar image

updated 2014-10-27 11:12:27 -0500

mpetason gravatar image

(.venv)jstack@:~/tempest_test/tempest$ nosetests -vx tempest.api.identity.admin.v3.test_users.py

ERROR: test suite for <class 'tempest.api.identity.admin.v3.test_users.UsersV3TestJSON'>
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 208, in run
    self.setUp()
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 291, in setUp
    self.setupContext(ancestor)
  File "/usr/lib/python2.7/dist-packages/nose/suite.py", line 314, in setupContext
    try_run(context, names)
  File "/usr/lib/python2.7/dist-packages/nose/util.py", line 471, in try_run
    return func()
  File "/home/jstack/tempest_test/tempest/tempest/test.py", line 264, in setUpClass
    cls.resource_setup()
  File "/home/jstack/tempest_test/tempest/tempest/api/identity/base.py", line 98, in resource_setup
    super(BaseIdentityV3AdminTest, cls).resource_setup()
  File "/home/jstack/tempest_test/tempest/tempest/api/identity/base.py", line 34, in resource_setup
    cls.os_adm = clients.AdminManager(interface=cls._interface)
  File "/home/jstack/tempest_test/tempest/tempest/clients.py", line 469, in __init__
    credentials=auth.get_default_credentials('identity_admin'),
  File "/home/jstack/tempest_test/tempest/tempest/auth.py", line 457, in get_default_credentials
    return get_credentials(fill_in=fill_in, credential_type=credential_type)
  File "/home/jstack/tempest_test/tempest/tempest/auth.py", line 487, in get_credentials
    creds = credential_class.get_default(credential_type)
  File "/home/jstack/tempest_test/tempest/tempest/auth.py", line 573, in get_default
    raise exceptions.InvalidConfiguration()
InvalidConfiguration: Invalid Configuration
Details: Invalid Configuration
-------------------- >> begin captured logging << --------------------
tempest.api.identity: DEBUG: Entering tempest.api.identity.setup_package
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-18 00:35:37 -0500

Even I am facing the same issue

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-27 04:09:26 -0500

Seen: 225 times

Last updated: Oct 27 '14