Ask Your Question
1

Endpoint does not support RPC version 3.33

asked 2014-10-26 01:04:33 -0500

Shikanda gravatar image

updated 2014-10-26 15:24:05 -0500

smaffulli gravatar image

Hi, I am running openstack juno on ubuntu 14.04.1lts and whenever I launch an instance using nova they get stuck in bulid state.

The logs for nova-compute.log:

2014-10-24 12:11:02.611 1523 ERROR oslo.messaging.rpc.dispatcher [-] Exception during message handling: Endpoint does not support RPC version 3.33
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher Traceback (most recent call last):
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 133, in _dispatch_and_reply
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher incoming.message))
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 185, in _dispatch
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher raise UnsupportedVersion(version)
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher UnsupportedVersion: Endpoint does not support RPC version 3.33
2014-10-24 12:11:02.611 1523 TRACE oslo.messaging.rpc.dispatcher
2014-10-24 12:11:02.612 1523 ERROR oslo.messaging._drivers.common [-] Returning exception Endpoint does not support RPC version 3.33 to caller
2014-10-24 12:11:02.612 1523 ERROR oslo.messaging._drivers.common [-] ['Traceback (most recent call last):\n', ' File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 133, in _dispatch_and_reply\n incoming.message))\n', ' File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 185, in _dispatch\n raise UnsupportedVersion(version)\n', 'UnsupportedVersion: Endpoint does not support RPC version 3.33\n']
2014-10-24 12:11:22.839 1523 AUDIT nova.compute.resource_tracker [-] Auditing locally available compute resources
2014-10-24 12:11:23.212 1523 AUDIT nova.compute.resource_tracker [-] Free ram (MB): 15496
2014-10-24 12:11:23.213 1523 AUDIT nova.compute.resource_tracker [-] Free disk (GB): 534
2014-10-24 12:11:23.213 1523 AUDIT nova.compute.resource_tracker [-] Free VCPUS: 4
2014-10-24 12:11:23.245 1523 INFO nova.compute.resource_tracker [-] Compute_service record updated for compute1:compute1

Any ideas on how to get past this hurdle?

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2014-10-27 11:18:15 -0500

mpetason gravatar image

You may be running a version of RabbitMQ ( or whichever messaging service you picked ) that is not new enough to handle RPC version 3.33:

'UnsupportedVersion: Endpoint does not support RPC version 3.33

See if there is an upgrade for the RabbitMQ version you are using on the controllers. Also verify that there aren't any updates needed for packages on the controller/computes.

edit flag offensive delete link more

Comments

Thanks. I was running an earlier version of RabbitMQ (3.2) So I got to update it (to 3.4.0), still same error

Shikanda gravatar imageShikanda ( 2014-10-28 02:21:53 -0500 )edit

Did you restart the service to see if it came back with the same error? See if there are any oslo updates or client updates/library updates for OpenStack services.

mpetason gravatar imagempetason ( 2014-10-28 10:12:31 -0500 )edit

Found out I had not added the juno repo on the compute node, silly me.

Anyway things are working now, except I can only ssh the instances from the controller node. I get a PermissionDenied error when I try to do so from other hosts on the LAN.

Shikanda gravatar imageShikanda ( 2014-10-30 04:14:12 -0500 )edit

You need to assign floating IP addresses to them and verify you have routing in your network to the Floating IP address pool. Then you need to verify that the security group isn't blocking everything, probably add SSH and ICMP access to default.

mpetason gravatar imagempetason ( 2014-10-30 09:22:05 -0500 )edit

The security group is set to accept traffic on port 22 so ssh is ok. I can actually ssh into the instance from the controller node and then ssh from the instance to a host on the LAN, but not from a host to the instance. I think its something to do with public keys, I don't know how to go about it

Shikanda gravatar imageShikanda ( 2014-10-31 01:42:02 -0500 )edit
0

answered 2015-09-07 07:52:19 -0500

mriedem gravatar image

Per the original question, it's not the version of rabbitmq that is the issue, it's the version of the compute RPC API you have, the 3.33 comes from this:

https://github.com/openstack/nova/blo...

So check to see that (1) you have that Juno code level on your compute nodes and (2) check to see if you have versions pinned via the upgrade_levels.compute config option in nova.conf. There is some more info on upgrade_levels in the docs here:

http://docs.openstack.org/openstack-o...

edit flag offensive delete link more
0

answered 2015-05-03 23:12:30 -0500

check the python-oslo.messaging version! correct is “1.4.1-0ubuntu1~cloud0 ”

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-26 01:04:33 -0500

Seen: 4,772 times

Last updated: Sep 07 '15