Ask Your Question
1

RDO Quickstart PackStack failure - files not installed

asked 2014-10-22 19:42:49 -0500

andrewv gravatar image

Followed simple PackStack installation - CentOS 7.0 with Icehouse - running in VirtualBox VM - output text indicates successful install with keystonerc_admin file installed in /root, but file not there. Installation output to screen and installation log look good and indicate successful installation. Any debug recommendations? Thanks

edit retag flag offensive close merge delete

Comments

Any chance to provide the full log somewhere? I would also check openstack-status output to see what if any services are up as that may give a hint to exactly which bits failed.

sgordon gravatar imagesgordon ( 2014-10-23 10:03:30 -0500 )edit

Same issue here. Fresh install on 7.0, no errors, but no file is written and no services are started. Log file is at http://home.comcast.net/~badger58/packstack.log (http://home.comcast.net/~badger58/pac...)

patrickt33 gravatar imagepatrickt33 ( 2014-10-24 10:26:05 -0500 )edit

I ran a strace on the install and found that it was unable to find puppet, which is because it wasn't installed. I've installed it and now get a new error: "Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list". There is no erlang package to install

patrickt33 gravatar imagepatrickt33 ( 2014-10-27 07:59:24 -0500 )edit

Looking at the trace, I see that erlang is a dependency for rabbitmq. Had to enable EPEL to try to install rabbitmq manually. it successfully installed a ton of erlang packages, but packstack still fails with the same error. manually search for erlang* it's successful. this is pretty frustrating.

patrickt33 gravatar imagepatrickt33 ( 2014-10-27 08:49:25 -0500 )edit

Well, we're getting new errors now. reinstalled OS and performed the following commands. I don't know how I'm supposed to post anything useful with this stupid character limit. Still not generating the mysterious file, but now the error has to do with starting nova-api service.error in next comment

patrickt33 gravatar imagepatrickt33 ( 2014-10-28 12:03:03 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-10-31 19:55:24 -0500

Alan Pevec gravatar image

Which openstack-packstack version do you have? Auto-enabling EPEL was missing in openstack-packstack-2014.1.1-0.29.dev1251 and should be fixed >= 2014.1.1-0.29.1.dev1251

edit flag offensive delete link more

Comments

openstack-packstack-2014.2-0.5.dev1316.g733aa73.el7.centos.noarch

It does not auto-enable EPEL. If I do that first thing, then it does work much better, although I do still have to manually add the nova and neutron users and put them in the wheel group.

patrickt33 gravatar imagepatrickt33 ( 2014-11-03 09:47:53 -0500 )edit
1

answered 2014-10-29 10:02:23 -0500

patrickt33 gravatar image

This is what worked for me. The errors were buried in the log files. Really, really surprised and disappointed these pre-reqs aren't better documented, or at least that there's not some better error checking and messaging available. This was done on a brand new CentOS 7.0.1406 install.

rpm -ivh http://yum.puppetlabs.com/puppetlabs-release-el-7.noarch.rpm
wget http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-2.noarch.rpm
rpm -ivh epel-release-7-2.noarch.rpm
sudo yum install -y https://rdo.fedorapeople.org/rdo-release.rpm
yum install openstack-packstack
useradd -m -s /bin/bash -G wheel nova
useradd -m -s /bin/bash -G wheel neutron

packstack --allinone
edit flag offensive delete link more

Comments

The dependencies are listed in the prerequisites section of the QuickStart @ https://openstack.redhat.com/QuickStart - the Puppet Labs repository is not required, puppet from EPEL can be used.

sgordon gravatar imagesgordon ( 2014-10-29 21:02:43 -0500 )edit

I saw those. I'm saying I think they're inadequate. If puppet is required, it should be on the list of prerequisites or installed by the packstack script. It also clearly says: "The packstack version in the RDO repositories, will auto enable EPEL" so I shoulcn't have to do anything at all.

patrickt33 gravatar imagepatrickt33 ( 2014-10-30 06:35:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-10-22 19:42:49 -0500

Seen: 1,479 times

Last updated: Oct 29 '14