Ask Your Question

juno installation error on RHEL 7

asked 2014-10-22 18:23:42 -0600

colossal gravatar image

updated 2014-10-22 20:46:30 -0600

larsks gravatar image


This command is throwing following error. Commands before that are working. Its a licensed RHEL.

Doc that im following is here.

yum install openstack-keystone python-keystoneclient


---> Package python-pycadf.noarch 0:0.6.0-2.el7.centos will be installed
--> Processing Dependency: python-webob >= 1.2.3 for package: python-pycadf-0.6.0-2.el7.centos.noarch
--> Finished Dependency Resolution
Error: Package: python-eventlet-0.15.2-1.el7.noarch (openstack-juno)
           Requires: python-greenlet
Error: Package: python-pycadf-0.6.0-2.el7.centos.noarch (openstack-juno)
           Requires: python-webob >= 1.2.3
Error: Package: python-keystonemiddleware-1.2.0-1.el7.centos.noarch (openstack-juno)
           Requires: python-webob
Error: Package: python-keystone-2014.2-0.6rc2.el7.centos.noarch (openstack-juno)
           Requires: python-webob >= 1.2.3
Error: Package: 1:python-keystoneclient-0.11.1-1.el7.centos.noarch (openstack-juno)
           Requires: python-webob
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
edit retag flag offensive close merge delete


If this is licensed RHEL, maybe you should be following instructions from Red Hat? They might be more helpful in the context of a RHEL 7 system. I think you may need to enable additional repositories.

larsks gravatar imagelarsks ( 2014-10-22 20:48:08 -0600 )edit

What repos do I have to enable? I ran the command using --enablerepo=epel too but it didnt help. I guess if it has proven to work well with Centos 7, it should work with RHEL 7 too !!

colossal gravatar imagecolossal ( 2014-10-23 13:14:44 -0600 )edit

Hi, colossal, I follow the (this) doc to configure OpenStack packages, and it works. And you can use openstack-packstack to simplify the installation

sanjeo gravatar imagesanjeo ( 2014-10-27 03:29:40 -0600 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2015-03-16 08:43:47 -0600

Praveen N gravatar image

updated 2015-03-16 08:48:12 -0600

That document (you are following) link is not working..!! You can give a try by

#yum install openstack-packstack --y
edit flag offensive delete link more

answered 2015-10-06 09:17:06 -0600

Raghavachari gravatar image

updated 2015-10-06 10:25:33 -0600

Noticed similar failure in my environment. Enabled additional repositories and it worked fine.

  • yum install (
  • subscription-manager repos --enable=rhel-7-server-extras-rpms
  • subscription-manager repos --enable=rhel-7-server-optional-rpms
  • subscription-manager repos --enable=rhel-ha-for-rhel-7-server-rpms
  • yum install yum-utils
  • yum install -y openstack-packstack
  • yum update
  • packstack --allinone
edit flag offensive delete link more

answered 2015-03-24 04:03:35 -0600

toon_peeters gravatar image

updated 2015-03-24 04:04:25 -0600

That solves the problem, but isn't it a work-around kind of way. Isn't there another option? I am wandering whether or not there are packages available for your machine, so that you can just add packages and the problem will be solved?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-10-22 18:23:42 -0600

Seen: 2,682 times

Last updated: Oct 06 '15