Launching Apache Tomcat inside VM takes up to 47 minutes [closed]

asked 2014-10-22 18:15:18 -0500

rrottach gravatar image

updated 2014-10-24 19:39:31 -0500

I found the issue i was having but i am not sure why it only effected the openstack vm's. Replacing securerandom.source=file:/dev/urandom with securerandom.source=file:/dev/./urandom from file $JAVA_PATH/jre/lib/security/ solved my problem. It now takes 30 secs from the time I reboot the server for the app to come up.


The question I have relates to the length of time it takes to access the tomcat server on an openstack vm. I currently have 2 stacks running in a production environment and 1 running in a development environment , which work great with the exception of the time it takes to access the application when the server is rebooted. It currently takes from 13-47 minutes before I can access our tomcat servers. Is there something that can be preventing access to these servers until some sort of timeout is reached? Tomcat uses ports 8009,8080,8443 redirecting 8009 and 8080 to 8443. The reboot time on our metal servers is approximately 3-4 minutes.

I use different flavors for different types of servers. 1 VCPU, 2048MB RAM, 100GB Disk, 2 VCPU, 8192MB RAM, 100GB Disk, 1 VCPU, 2048MB RAM, 20GB Disk, 2000MB SWAP, 1VCPU 4096MB RAM 120GB Disk

I have searched through apache2, tomcat, nova logs and have found nothing out of the ordinary

OS: Ubuntu 14.04
OpenStack: Juno
Apache2: Apache/2.4.7
Tomcat7: Apache Tomcat/7.0.52 (Ubuntu)
Java: java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.2) (7u65-2.5.2-3~14.04)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

Any thoughts would be greatly appreciated Russell Rottach Maplewood Software Inc

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by rrottach
close date 2014-10-24 19:45:37.713565


what flavors do you use for the VMs? Anything in the logs? update the question.

smaffulli gravatar imagesmaffulli ( 2014-10-24 14:08:22 -0500 )edit