Ask Your Question

Error with neutron service on the controller: Connection to neutron failed: HTTPConnectionPool [closed]

asked 2014-10-21 10:37:32 -0500

Gonzo gravatar image

Hi All,

I am newbie in OpenStack and I am evaluating it on my home with 3 nodes environment, how the doc says (controller node, network node and compute node).

I am installing it on Debian and I have a problem at the end of the installation process when I am trying to create one network tenant. From the controller node I type "neutron net-create demo-net" and I get this error:

# neutron net-create demo-net
Connection to neutron failed: HTTPConnectionPool(host='', port=9696): Max retries exceeded with url: /v2.0/networks.json (Caused by ProtocolError('Connection aborted.', error(111, 'Conexi\xc3\xb3n rehusada')))

Neutron is running on control node:

# ps aux | grep neutron
neutron  27341  0.5  1.7  71736 52860 ?        S    16:57   0:06 /usr/bin/python2.7 /usr/bin/neutron-server --config-file=/etc/neutron/neutron.conf --log-file=/var/log/neutron/neutron-server.log

But it is strange because I see it no running on 9696 port:

# netstat -putona | grep 9696

...despite I have uncommented it on /etc/neutron/neutron.conf:

# Port the bind the API server to
bind_port = 9696

The only errors I can see in /var/log/neutron/neutron-server.log are related to issues with connecting with rabbitmq:

2014-10-21 17:20:21.685 27341 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on controlnode:5672
2014-10-21 17:20:24.719 27341 ERROR neutron.openstack.common.rpc.common [-] AMQP server on controlnode:5672 is unreachable: Socket closed. Trying again in 30 seconds.

... and If this is the issue why neutron is not starting on (and the main reasson for I can not create one tenant network), it is very weird because rabbitmq is running on the same controller node host and listening on that port:

# nc -vz controlnode 5672 [] 5672 (amqp) open

# ps aux | grep rabbit
rabbitmq 26289  0.8  0.8 119524 26624 ?        Sl   16:20   0:32 
...-rabbit tcp_listeners [{"",5672}]...

Any help will be much appreciated. Because I am stalled on this point of the installation when going to create one tenant network.

Thank you,


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Gonzo
close date 2014-10-22 10:04:47.389355


Make sure ports 9696 and 5672 are open in iptables

# iptables-save | grep port_number
dbaxps gravatar imagedbaxps ( 2014-10-21 11:22:24 -0500 )edit

There are similar questions on this site with some suggestions on things to try. Check for example. Edit the question as find out more.

smaffulli gravatar imagesmaffulli ( 2014-10-21 11:22:46 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-10-22 10:02:54 -0500

Gonzo gravatar image

Yes!. Thank you very much. The second link pointed to me into the right direction. In rabbitmq, user 'guest' can only connect via localhost. And I had configured his external IP.

So I did:

- change /etc/rabbitmq/rabbitmq-env.conf to
- change /etc/neutron/neutron.conf -> rabbit_host to
- rabbitmqctl change_password guest..... to my password again
- service rabbitmq-server restart
- service neutron-server restart

And now I can create the tenant network.

Thank you ;)


edit flag offensive delete link more


i am facing problem of maximum attempt reached, and neutron server is not listening on port 9696. please help. my each and every configuration file is ok.. rabbit server and neutron server are succesfully running.

hpetwal gravatar imagehpetwal ( 2015-04-20 02:48:46 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-10-21 10:37:32 -0500

Seen: 4,971 times

Last updated: Oct 22 '14