Ask Your Question
0

not create a listening tcp socket on the port 9696, not connection to neutron

asked 2014-10-20 04:23:32 -0500

zhalin gravatar image

hi anyone, i real need help, please guid me about this problem in neutron when i run "neutron net-create ext-net --shared --router:external=True" and return "unable to establish connection to http://controller:9696/v2.0/networks.json%22 (http://controller:9696/v2.0/networks....) . i use ubuntu server 12.4 and openstack icehouse. I am waiting to help you, thanks regards

edit retag flag offensive close merge delete

Comments

i look server.log there are warnings and errors: 2014-10-11 01:12:21.273 3572 ERROR neutron.openstack.common.rpc.common [-] AMQP server on localhost:5672 is unreachable:socket closed. trying again in 30 seconds.

zhalin gravatar imagezhalin ( 2014-10-20 04:42:08 -0500 )edit

rabbitmq/qpid is not running, assuming you're running a single node setup. If multinode, check where you're running rabbitmq/qpid and make sure rabbit_host is properly configured in neutron.conf

vthapar gravatar imagevthapar ( 2014-10-20 05:11:52 -0500 )edit

Make sure ports 9696 and 5672 are open in iptables , whatever version of firewall you are running on Precise
Make sure neutron-server and rabbitmq-server are up running controller. It looks like compute node cannot establish TCP/IP connections with your controller node.

DanIzack gravatar imageDanIzack ( 2014-10-20 06:21:44 -0500 )edit

how to check ports are open in iptables? ii check with "netstat -ln | grep 9696", "iptables-save | grep 9696" but return no output. i think to close this port, what do i have to do to solve this problem? thanks your attention

zhalin gravatar imagezhalin ( 2014-10-20 11:27:38 -0500 )edit

i run "netstat -ln | grep 5672" return "tcp6 0 0 ::: 5672 :::* LISTEN"

zhalin gravatar imagezhalin ( 2014-10-20 12:01:16 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-05-09 02:37:30 -0500

exergy gravatar image

It can happen because of multiple reasons few of them are enlisted below.

  1. Incorrect IP/hostname/password in configuration files in neutron.conf or nova.conf across compute, controller and network node acn cause this. It was the problem statement in my scenario. I corrected it and it worked pretty well after that.
  2. Ensure neutron-linux-bridge service is up and running on controller and neutron node.
  3. Ensure basic entries in etc/hosts files are correct across nodes.
  4. Ensure relevant ports are open in IP tables.
edit flag offensive delete link more
0

answered 2014-10-20 06:26:55 -0500

DanIzack gravatar image

Make sure ports 9696 and 5672 are open in iptables , whatever version of firewall you are running on Precise. Make sure neutron-server and rabbitmq-server are up and running controller. It looks like compute node cannot establish TCP/IP connections with your controller node.

edit flag offensive delete link more
0

answered 2014-10-20 05:24:47 -0500

RHK gravatar image

This happens when your credentials are wrong. Make sure the rabbit_user and rabbit_password match.

Try this,

rabbitmqctl change-password guest guest

Check the line in your neutron.conf file.

rabbit_host = 10.0.0.11 (correct host name/ipaddress)

Regards,
RHK

edit flag offensive delete link more

Comments

thanks your answer, icheck but again return same error

zhalin gravatar imagezhalin ( 2014-10-20 05:37:30 -0500 )edit

if it is possible for you help me more. thanks

zhalin gravatar imagezhalin ( 2014-10-20 05:43:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-20 04:23:32 -0500

Seen: 2,823 times

Last updated: May 09 '17