Ask Your Question
0

I want to upload a windows xp image to openstack.But all the time its failing. [closed]

asked 2013-09-18 01:38:54 -0500

Cloudie gravatar image

I have tried two methods.

  1. Launched ISO from virt-manager GUI. and created .img and uploaded via glance add command.

2. I did from terminal using virt-install and got a .qcow2 file ..then uploaded qcow2 with glance add

All the time i am getting error like NO BOOTABLE DEVICE PLS HELP

Thanks In advance :)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-08-10 17:16:23.691993

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-09-20 04:07:48 -0500

Anand TS gravatar image

The problem with launching windows image with openstack can be solved if you install the VirtIO drives properly.

While Using the virtual machine manager (GUI) from the host to launch windows image, note that you have properly installed Redhat SCSI controller and Redhat ethernet adapter.

I faced similar issues and it is solved when I installed both while installation.(Can be done after installation also). After that try to upload windows.img (say) to glance. It will be saved in /var/lib/libvirt/images by default.

From Dashboard you can easily launch windows image by selecting raw as disk format.

Regards, Anand

edit flag offensive delete link more

Comments

thanks bro :)

Cloudie gravatar imageCloudie ( 2013-10-08 03:02:33 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2013-09-18 01:38:54 -0500

Seen: 1,330 times

Last updated: Sep 20 '13