How to specify multiple interface mappings for LinuxBridge plugin?

asked 2013-09-17 20:03:58 -0600

scott-devoid gravatar image

updated 2013-09-19 12:13:13 -0600

darragh-oreilly gravatar image

From the OpenStack Networking Guide

The suggested configuration for /etc/quantum/plugins/linuxbridge/linuxbridge_config.ini to implement a single public network with multiple VLAN tenant networks is:

tenant_network_type = vlan
network_vlan_ranges = physnet2:100:110

physical_interface_mappings: physnet2:eth1

However it is not clear from this how the external network is defined. If amend the bridge section:

physical_interface_mappings: physnet2:eth1,physnet3:eth1

This raises an execption in /var/log/quantum/server.log on startup. If I amend the vlan section:

tenant_network_type = vlan
network_vlan_ranges = physnet2:100:110,physnet1

This works, but it's not clear if I can set that physical network as having no VLAN range (I can still create a network with a --provider:network_type vlan...

Furthermore, I cannot add multiple physical_interface_mapping entries. E.g.

physical_interface_mappings: physnet2:eth1,physnet3:eth2

Just makes everything unhappy.

edit retag flag offensive close merge delete


Are you making a distinction between the ":" and "=" as the key/value separator?

scott-devoid gravatar imagescott-devoid ( 2013-09-18 12:46:14 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2013-09-17 22:27:30 -0600

darragh-oreilly gravatar image

updated 2013-09-19 12:17:13 -0600

That must be a doc bug. It should be:

physical_interface_mappings = physnet2:eth1

Or for multiple mappings it is a comma separated list like:

physical_interface_mappings = physnet2:eth1,physnet3:eth2

The key-value separator in the main value is :

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-09-17 20:03:58 -0600

Seen: 3,852 times

Last updated: Sep 19 '13