Ask Your Question

Does the neutron support IP packet fragmentation ?

asked 2014-10-16 10:55:15 -0500

sky gravatar image

I found that "ping x.x.x. -s 2000" didn't work.(ping packet size option=2000 bytes was used for fragmentation).

I tested it from VM instance to Host in External network and vice versa. However, both case didn't work. It seems like the neutron doesn't handle the fragmented IP packets properly.

You can easily replicate this issue. I installed open-stack(Three-node archtecture with OpenStack Networking(neutron)) according to OpenStack Installation Guide for Ubuntu12.04/14.04.

Is there something that I didn't configure?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-10-16 12:00:48 -0500

dbaxps gravatar image

updated 2014-10-16 12:11:01 -0500

That is done from within fedora 20 instance :-

[root@vf20twrs0810 ~]# uname -a
Linux vf20twrs0810.novalocal 3.16.4-200.fc20.x86_64 #1 SMP Mon Oct 6 12:57:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[root@vf20twrs0810 ~]# ping -s 2000
PING ( 2000(2028) bytes of data.
2008 bytes from icmp_seq=1 ttl=63 time=2.92 ms
2008 bytes from icmp_seq=2 ttl=63 time=2.19 ms
2008 bytes from icmp_seq=3 ttl=63 time=2.14 ms
2008 bytes from icmp_seq=4 ttl=63 time=2.22 ms
2008 bytes from icmp_seq=5 ttl=63 time=2.13 ms
2008 bytes from icmp_seq=6 ttl=63 time=2.16 ms
--- ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5006ms
rtt min/avg/max/mdev = 2.133/2.298/2.921/0.282 ms
[root@vf20twrs0810 ~]# ping -s 2700
PING ( 2700(2728) bytes of data.
2708 bytes from icmp_seq=1 ttl=63 time=2.92 ms
2708 bytes from icmp_seq=2 ttl=63 time=2.45 ms
2708 bytes from icmp_seq=3 ttl=63 time=2.48 ms
2708 bytes from icmp_seq=4 ttl=63 time=2.49 ms
2708 bytes from icmp_seq=5 ttl=63 time=2.46 ms
--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 2.453/2.565/2.926/0.181 ms

[root@vf20twrs0810 ~]# ethtool -k eth0
Features for eth0:
rx-checksumming: on [fixed]
tx-checksumming: on
    tx-checksum-ipv4: off [fixed]
    tx-checksum-ip-generic: on
    tx-checksum-ipv6: off [fixed]
    tx-checksum-fcoe-crc: off [fixed]
    tx-checksum-sctp: off [fixed]
scatter-gather: on
    tx-scatter-gather: on
    tx-scatter-gather-fraglist: on
tcp-segmentation-offload: on
    tx-tcp-segmentation: on
    tx-tcp-ecn-segmentation: on
    tx-tcp6-segmentation: on
udp-fragmentation-offload: on
generic-segmentation-offload: on
generic-receive-offload: on
large-receive-offload: off [fixed]
rx-vlan-offload: off [fixed]
tx-vlan-offload: off [fixed]
ntuple-filters: off [fixed]
receive-hashing: off [fixed]
highdma: on [fixed]
rx-vlan-filter: on [fixed]
vlan-challenged: off [fixed]
tx-lockless: off [fixed]
netns-local: off [fixed]
tx-gso-robust: off [fixed]
tx-fcoe-segmentation: off [fixed]
tx-gre-segmentation: off [fixed]
tx-ipip-segmentation: off [fixed]
tx-sit-segmentation: off [fixed]
tx-udp_tnl-segmentation: off [fixed]
tx-mpls-segmentation: off [fixed]
fcoe-mtu: off [fixed]
tx-nocache-copy: off
loopback: off [fixed]
rx-fcs: off [fixed]
rx-all: off [fixed]
tx-vlan-stag-hw-insert: off [fixed]
rx-vlan-stag-hw-parse: off [fixed]
rx-vlan-stag-filter: off [fixed]
l2-fwd-offload: off [fixed]
busy-poll: off [fixed]

Pinging floating IP of same VM

[boris@icehouse1 Downloads]$ ping -s 2000
PING ( 2000(2028) bytes of data.
2008 bytes from icmp_seq=1 ttl=63 time=1.42 ms
2008 bytes from icmp_seq=2 ttl=63 time=0.904 ms
2008 bytes from 192.168 ...
edit flag offensive delete link more


I installed it on Ubuntu14.04. I captured pcap on eth0(VM-instance) and eth1(ComputeNode). All fragmented IP packets were shown on eth0(VM-instance) but only one fragmented ip packet was shown on eth1(Compute Node). Some fragmented packets disappeared somewhere. Do you think it is related to ubuntu?

sky gravatar imagesky ( 2014-10-16 14:24:36 -0500 )edit

Does your system && VMs work properly with usual ping,curl ?
I always stay away from Ubuntu , but it should not be matter regarding packet fragmentation.
Run from within VM : ethtool -k eth0

dbaxps gravatar imagedbaxps ( 2014-10-16 14:46:24 -0500 )edit

root@vmdev151:~# ethtool -k eth0 Offload parameters for eth0: Cannot get device rx csum settings: Operation not supported Cannot get device flags: Operation not supported rx-checksumming: off tx-checksumming: on scatter-gather: on tcp-segmentation-offload: on udp-fragmentation-offload: on

sky gravatar imagesky ( 2014-10-16 17:23:48 -0500 )edit

generic-segmentation-offload: on generic-receive-offload: off large-receive-offload: off root@vmdev151:~#

Above is the information from my vm-instance that runs on the compute node.

sky gravatar imagesky ( 2014-10-16 17:24:41 -0500 )edit

Thank you for your comments.

I used MTU size = 1500. I don't have any idea on what I have to take a look at.

sky gravatar imagesky ( 2014-10-16 17:27:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-10-16 10:55:15 -0500

Seen: 923 times

Last updated: Oct 16 '14