Ask Your Question
0

RDO deploy openstack, Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list

asked 2014-10-14 00:48:36 -0500

LinusFang gravatar image

updated 2014-10-18 05:09:01 -0500

Issue: Last week I used RDO quick start to install openstack for controller node, it was successfull. But yesterday, when I install another server as controller node. There are below errors. Can any one help ?

Applying 9.186.169.31_amqp.pp

Applying 9.186.169.31_mariadb.pp

9.186.169.31_amqp.pp: [ ERROR ]

Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 9.186.169.31_amqp.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list erlang' returned 1: Error: No matching Packages to list
You will find full trace in log /var/tmp/packstack/20141014-123922-r869MX/manifests/9.186.169.31_amqp.pp.log
Please check log file /var/tmp/packstack/20141014-123922-r869MX/openstack-setup.log for more information
edit retag flag offensive close merge delete

Comments

Setup EPEL 7 for CentOS 7 or EPEL 6 for for CentOS 6.5 and try :
/usr/bin/yum -d 0 -e 0 -y list erlang

dbaxps gravatar imagedbaxps ( 2014-10-14 06:10:09 -0500 )edit

6 answers

Sort by » oldest newest most voted
0

answered 2014-10-22 01:11:22 -0500

I got same error and EPEL WAS already installed as well. Than I installed Erlang package by using below command.

Yum --enablerepo=epel info erlang

Yum --enablerepo=epel install erlang

1st check Erlang package is available in epel if not than update epel.

After that use that command. And problem solved.

edit flag offensive delete link more
0

answered 2014-10-14 07:49:01 -0500

dbaxps gravatar image

updated 2014-10-18 05:20:55 -0500

Setup EPEL 7 for CentOS 7 or EPEL 6 for for CentOS 6.5 and try :
/usr/bin/yum -d 0 -e 0 -y list erlang

[root@icehouse1 ~(keystone_admin)]# /usr/bin/yum -d 0 -e 0 list erlang
Installed Packages
erlang.x86_64                                     R16B-03.7.el7                                     @epel

View also recent thread https://ask.openstack.org/en/question...
regarding your most recent update.

edit flag offensive delete link more

Comments

It's weird, I have install EPEL for RHEL6.5, but still shows the same error.

[root@controller yum.repos.d]# ll total 24 -rw-r--r--. 1 root root 957 Oct 14 21:35 epel.repo -rw-r--r--. 1 root root 1056 Nov 5 2012 epel-testing.repo -rw-r--r--. 1 root root 707 Oct 14 16:52 foreman.repo

LinusFang gravatar imageLinusFang ( 2014-10-14 08:39:23 -0500 )edit

[root@controller yum.repos.d]# rpm -qa | grep epel epel-release-6-8.noarch

LinusFang gravatar imageLinusFang ( 2014-10-14 08:40:02 -0500 )edit

Inside *.repo file try to switch to $baseurl from $mirrorlist

dbaxps gravatar imagedbaxps ( 2014-10-14 09:30:42 -0500 )edit

you have to modify the epel.repo file after you execute packstack command,because packstack will disable epel repo ,show you a segment of packstack logs:

2014-10-17 22:11:27::INFO::shell::81::root:: [10.0.3.15] Executing script: yum-config-manager --disable epel

Haifeng gravatar imageHaifeng ( 2014-10-17 23:01:01 -0500 )edit
0

answered 2014-10-14 09:54:24 -0500

bishoy gravatar image

are you sure you are using the right repos? because yes it can be changed tomorrow. So, try to use the updated repo and check the url yourself. sometimes you will find the url working but a the packages moved o another dir. so adjust it in the sources and retry the installation.

edit flag offensive delete link more
0

answered 2014-10-14 09:52:43 -0500

Set enable=1 in the epel.list file, sometimes i don't know why but RDO disable this option. May happen several times during your installation. First install the needed packages and then re run packstack

edit flag offensive delete link more

Comments

the packstack disable epel ,the install logs show these:

2014-10-17 22:11:27::INFO::shell::81::root:: [10.0.3.15] Executing script: yum-config-manager --disable epel

Haifeng gravatar imageHaifeng ( 2014-10-17 22:57:43 -0500 )edit
0

answered 2014-10-14 15:01:58 -0500

Jannis gravatar image

EPEL was my problem as well. This helped me: http://www.tecmint.com/how-to-enable-epel-repository-for-rhel-centos-6-5/ (http://www.tecmint.com/how-to-enable-...)

edit flag offensive delete link more
0

answered 2014-10-17 23:31:18 -0500

Haifeng gravatar image

the same as me,I have reported a bug on launchpad:https://bugs.launchpad.net/packstack/+bug/1382731

FWIW, the same issue has recently been reported on the Japan OpenStack User Group mailing list: https://groups.google.com/forum/#!topic/openstack-ja/b6wojDFUw40 (https://groups.google.com/forum/#!top...)

The easy workaround is to use --use-epel=y, but it's still a bug as Packstack is supposed to recognize enterprise distros automatically and enable EPEL instead of disable it.

edit flag offensive delete link more

Comments

1

if packstack --allinone,the default value of epel option now is "CONFIG_USE_EPEL=n",you can execute "#yum-config-manager --enable epel" after "Preparing servers [ DONE ]" to enable epel repo

Haifeng gravatar imageHaifeng ( 2014-10-19 00:46:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-10-14 00:48:36 -0500

Seen: 4,282 times

Last updated: Oct 22 '14