Ask Your Question
0

Ntp configuration in nodes

asked 2014-10-12 03:39:43 -0600

D20K gravatar image

In a new installation of ICEhouse on Window8.1 Host and VMware VMs - 3 node configuration, I don't know how to configure ntp all nodes.

Ther are 3 node Controller Node , Network Node and Compute Node. I want to configure controller node to get time with externel internet and network, compute node to get time sync with controller node.

I install ntp all nodes and in network, compute node I comment server list in /etc/ntp.conf and add server controller like this:

# server 0.ubuntu.pool.ntp.org
# server 1.ubuntu.pool.ntp.org
# server 2.ubuntu.pool.ntp.org
# server 3.ubuntu.pool.ntp.org

# Use Ubuntu's ntp server as a fallback.
# server ntp.ubuntu.com
server controller

and service ntp restart. when I check with ntpq -p, it shows like:

 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 controller      .INIT.          16 u    -  256    0    0.000    0.000   0.000

Is this correct confiugration? I know return *controller is correct result..

Is there more configuration? plz help me..

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-10-12 21:11:01 -0600

updated 2014-10-12 21:11:57 -0600

Check to make sure you either have no 'restrict' entries, or a restrict to allow access.
For example my controller node is 10.0.0.11. Below will allow anything on the 10. segment to sync.

restrict 10.0.0.0 mask 255.255.255.0 nomodify notrap

Replace your segment and mask with your network configuration, then restart ntp.
I think you can remove all 'restrict' entires in ntp.conf which is an 'allow all'- but im not 100% sure.

edit flag offensive delete link more

Comments

I reinstall ntp and remove all restrict entries, it works well! :) thanks for advice

D20K gravatar imageD20K ( 2014-10-13 01:43:36 -0600 )edit
0

answered 2014-10-12 23:49:53 -0600

Vinoth gravatar image

This is ok for ntp client to fetch date & time from controller (ntp server). Also make sure, does your date & time is same in all three node after running ntpq -p command which is the result we want.

edit flag offensive delete link more

Comments

thanks for advcie :) I reinstall ntp and no configure in controller node and comment all server, add server controller. It works! I don't know why it doesn't work before..

D20K gravatar imageD20K ( 2014-10-13 01:42:23 -0600 )edit

@Vinoth, i've 3 controllers,3computes, 3ceph nodes. NTP is synced to 0.centos.pool.ntp.org The date/time shows a difference of 1 min across these nodes. Please suggest how to make time same across all these nodes.

CloudEnthusiast gravatar imageCloudEnthusiast ( 2018-01-29 21:08:11 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-12 03:39:43 -0600

Seen: 1,894 times

Last updated: Oct 12 '14