Ask Your Question
0

dpkg: error processing package cinder-common (--configure):

asked 2014-10-12 00:56:55 -0600

D20K gravatar image

updated 2014-10-12 00:58:13 -0600

In a new installation of ICEhouse on Ubuntu 14.04 Host and VMware VMs - 3 node configuration at the point where install cinder-api and cinder-scheduler in controller, I get this error:

Setting up cinder-common (1:2014.1.2-0ubuntu1) ...
Traceback (most recent call last):
   File "/usr/bin/cinder-manage", line 62, in <module>
      from oslo import messaging
ImportError: cannot import name messaging
dpkg: error processing package cinder-common (--configure):
  subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cinder-api:
   cinder-api depends on cinder-common (= 1:2014.1.2-0ubuntu1); however:
      Package cinder-common is not configured yet.

dpkg: error processing package cinder-api (--configure):
   dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cinder-scheduler:No apport report written because the error message indicates its a followup error from a previou    s failure.

 cinder-scheduler depends on cinder-common (= 1:2014.1.2-0ubuntu1); however:
    Package cinder-common is not configured yet.

dpkg: error processing package cinder-scheduler (--configure):
    dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                      Errors were encountered while processing:
 cinder-common
 cinder-api
 cinder-scheduler
 E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried like this:

apt-get remove cinder-common cinder-api cinder-common
apt-get update && apt-get upgrade
apt-get install cinder-api cinder-scheduler

but problem didn't get resolved. Can you tell me how to resolve this problem?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-10-12 01:47:33 -0600

D20K gravatar image

I got resolve this problem.

File "/usr/bin/cinder-manage", line 62, in <module>
  from oslo import messaging

in oslo.messaging it couldn't call Python.h file so I download Python.h file and it works well

sudo apt-get install python-dev

edit flag offensive delete link more

Comments

I tired this without success. Got a clean install of python-dev but still getting the same message when trying to install Cinder.

optimusB gravatar imageoptimusB ( 2014-10-12 21:17:56 -0600 )edit

Well.. try like this: pip install oslo.messaging --ugrade and restart cinder services.

D20K gravatar imageD20K ( 2014-10-13 01:45:48 -0600 )edit

This worked! Thanks.

optimusB gravatar imageoptimusB ( 2014-10-15 21:22:18 -0600 )edit
0

answered 2014-12-22 00:35:53 -0600

Harsh Mehta gravatar image

I got the same error. And i found the solution.

I also do sudo apt-get install python-dev but i didn't works for me.

Then i got a solution.

Solution: sudo pip install -- upgrade oslo.messaging

I hope it will help other.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-12 00:56:55 -0600

Seen: 1,342 times

Last updated: Oct 12 '14