Ask Your Question

Trying to integrate VMs to existing LAN

asked 2013-04-24 08:58:56 -0500

symydo gravatar image

updated 2013-06-11 10:26:49 -0500

fifieldt gravatar image

Hi! I'm trying to integrate Folsom VMs to my existing LAN with my corporate DHCP server. I have 2 node installation (controller node with nova-network and compute node). Installation looks good and VMs are getting IPs from my corporate DHCP server successfully but I cannot ping/ssh to any VM (default security group allows me to do so). Also VMs cannot interact with another VMs and also with my LAN.

Here more details:

edit retag flag offensive close merge delete


Shepard - I am having an issue getting the VMs on existing network. See the post:

I see your configuration works in this kind of environment. Can you please help me with the issue?

abhish gravatar imageabhish ( 2015-10-22 00:44:53 -0500 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2013-04-24 10:03:19 -0500

updated 2013-04-29 16:11:45 -0500

I think your bridge on compute node isn't ok, you have just br100 interface as I see. Eth0 should be linked to your corporate lan and br100 to nova network.

For better understanding of flat networking take a look here:

Here is how I did integration to existing LAN (network is

Controller and compute node - nova.conf

Controller node

nova-manage network create private --fixed_range_v4= --bridge_interface=br100 --num_networks=1 --network_size=256

Compute node

# Disable KVM default virtual bridge to avoid any confusion
virsh net-destroy default
virsh net-undefine default
apt-get install -y bridge-utils
ip link set eth0 promisc on
vim /etc/network/interfaces

auto br100 
iface br100 inet static 
bridge_stp off
bridge_fd 0

brctl addbr br100

/etc/init.d/networking restart

Both nodes have just one eth0 interface with static IPs. Quantum is not used and it worked on Folsom and now on Grizzly.

edit flag offensive delete link more

answered 2013-04-24 09:47:33 -0500

Hi, do you have created network in nova? You can check with:

nova-manage network list

And here is command to create it:

nova-manage network create private --fixed_range_v4= --bridge_interface=br100 --num_networks=1 --network_size=256
edit flag offensive delete link more


Hi, Yes I created one. Here it is:

nova-manage network list 5 None None None None b6bbd95f-2f64-4001-8e83-78f4f1077aff

symydo gravatar imagesymydo ( 2013-04-24 09:53:50 -0500 )edit

Example: auto eth0 iface eth0 inet static address netmask gateway dns-nameservers

auto br100 iface br100 inet static address netmask bridgestp off bridgefd 0

Alen Komljen gravatar imageAlen Komljen ( 2013-04-24 10:07:12 -0500 )edit

I see that br100 interface has no ports, is that ok? or it should be bounded to second interface?

symydo gravatar imagesymydo ( 2013-04-24 10:09:11 -0500 )edit

I've added br100 interface and now VMs are not getting IPs from my DHCP server. The link is good, but not helped. =(

symydo gravatar imagesymydo ( 2013-04-24 10:18:13 -0500 )edit

answered 2013-04-29 12:49:01 -0500

jzwiep gravatar image

Heres a solution that worked for us in Essex (not sure about Folsom):

Basically, it involves essentially disabling nova-network via editing the libvirt.xml.template file. The major downside to this 'fix' is that OpenStack's api will no longer be aware of each instances ip address, and so things like HTTP metadata break.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2013-04-24 08:58:56 -0500

Seen: 2,474 times

Last updated: Apr 29 '13