Ask Your Question
1

Grizzly sandbox: VM does not get DHCP IP

asked 2013-09-16 08:26:55 -0500

sph gravatar image

updated 2014-01-22 15:13:08 -0500

Evgeny gravatar image

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-26 08:47:29 -0500

sph gravatar image

Hi,

Thanks for the update. I ran the command on the controller and got the following output:

+--------------------------------------+--------------------+----------------------+-------+----------------+
| id       |agent_type         | host                 | alive | admin_state_up |
+--------------------------------------+--------------------+----------------------+-------+----------------+
| a3f053d0-51a9-4c9f-8551-3d236379158b | DHCP agent         | openstack-network-vm | xxx   | True           |
| 64889f49-7b59-4a90-9caa-99ebf96a5cdf | L3 agent           | openstack-network-vm | xxx   | True           |
| fb0fa712-dda3-40ab-be63-82ba7064f358 | Open vSwitch agent | openstack-network-vm | xxx   | True           |
| a06c2ecd-8756-4d18-a810-3fc78819eeb7 | DHCP agent         | debian-linux-1       | :-)   | True           |
| 625e0be6-a174-47ec-b6e7-ad707caa8df0 | L3 agent           | debian-linux-1       | :-)   | True           |
| d6e75ad6-518b-436c-8bb1-96ec429bb68c | Open vSwitch agent | debian-linux-1       | :-)   | True           |
+--------------------------------------+--------------------+----------------------+-------+----------------+

It is showing xxx in the alive column for the network node. but when I do a ps -ef |grep for the agent service I can see it running. I even restarted the following agents on network:

#  ls /etc/init.d/quantum-* | while read svc; do $svc restart; done

Restarting OpenStack Quantum DHCP agent: quantum-dhcp-agent.
Restarting OpenStack Quantum L3 agent: quantum-l3-agent.
Restarting OpenStack Quantum Metadata Agent: quantum-metadata-agent.
Restarting Openstack Quantum OpenVSwitch Plugin Agent: quantum-openvswitch-agent.

which restarted necessary quantum services. Yet, it shows xxx for the agent-list output for network node. I don't know why this would happen if the services are running.

edit flag offensive delete link more

Comments

Do you can paste the logs from your quantum* (host network)?

marcelodieder gravatar imagemarcelodieder ( 2013-09-27 00:55:27 -0500 )edit

Following is the link for ovs-agent.log, dhcp-agent.log, and l3-agent.log from compute node: http://pastebin.com/syDf6Xj5 There are errors in ovs-agent.log which are similar to those mentioned in this link - http://goo.gl/XdlO4 But they don't lead me to any answer as I haven't played with ovs before.

sph gravatar imagesph ( 2013-09-30 08:35:00 -0500 )edit

The logs are from your compute node? You also need past logs from your network node.

marcelodieder gravatar imagemarcelodieder ( 2013-10-01 07:05:51 -0500 )edit

Following are the network node logs: http://pastebin.com/CPTprx9K I don't see any errors on the network node thought. Are there any additional debugging steps I can do? Thanks for your time.

sph gravatar imagesph ( 2013-10-06 23:38:19 -0500 )edit

Try restart the openvswitch on both hosts. # /etc/init.d/openvswitch-switch restart and after restart quantum services. ls /etc/init.d/quantum-* | while read svc; do $svc restart; done After, see the logs for warn or err logs (quantum logs and openvswitch-agent.log).

marcelodieder gravatar imagemarcelodieder ( 2013-10-09 22:55:20 -0500 )edit
0

answered 2013-09-24 23:26:22 -0500

marcelodieder gravatar image

The quantum has plugins actives?

Run the command on one of your nodes:

# quantum agent-list

You installed the nodes on some hypervisor?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-16 08:26:55 -0500

Seen: 882 times

Last updated: Sep 26 '13