Ask Your Question
1

How to solve openstack instance error "no valid host found"?

asked 2014-10-10 04:30:49 -0500

vishgarg gravatar image

updated 2014-10-10 05:21:36 -0500

I've deployed openstack using juju and tried to launch a new instance which gives an error "no valid host was found". I've checked out other questions on this community and across the web with same problem and tried all but, nothing seems to work for me. I've also tried to create a volume from an image and then launch an instance but, nothing works.

nova-manage service list is showing all is correct.

Output of nova-manage service list:

Binary           Host                                 Zone             Status     State Updated_At
nova-cert        nodethreehcl                         internal         enabled    :-)   2014-10-10 10:21:08
nova-scheduler   nodethreehcl                         internal         enabled    :-)   2014-10-10 10:21:17
nova-conductor   nodethreehcl                         internal         enabled    :-)   2014-10-10 10:21:10
nova-compute     nodefivedell                         nova             enabled    :-)   2014-10-10 10:21:09
nova-network     nodefivedell                         internal         enabled    :-)   2014-10-10 10:21:14
nova-compute     nodeoneibm                           nova             enabled    :-)   2014-10-10 10:21:10
nova-network     nodeoneibm                           internal         enabled    :-)   2014-10-10 10:21:14
nova-compute     nodefourdell                         nova             enabled    :-)   2014-10-10 10:21:13
nova-network     nodefourdell                         internal         enabled    :-)   2014-10-10 10:21:11

here is some nova-scheduler log:

2014-10-09 09:09:20.887 5395 INFO oslo.messaging._drivers.impl_rabbit [-] Reconnecting to AMQP server on localhost:5672 2014-10-09 09:09:20.887 5395 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying reconnect for 1.0 seconds... 2014-10-09 09:09:21.898 5395 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 25 se conds. 2014-10-09 09:09:46.905 5395 INFO oslo.messaging._drivers.impl_rabbit [-] Reconnecting to AMQP server on localhost:5672 2014-10-09 09:09:46.905 5395 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying reconnect for 1.0 seconds... 2014-10-09 09:09:47.915 5395 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on localhost:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 27 se conds. 2014-10-09 11:04:33.915 19829 WARNING nova.scheduler.driver [req-72151d54-0d5d-4478-8d89-47154defd5c0 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f914a18]  [instance: 39e0494c-6c75-46a0-b8b0-e45f9d52cd37] Setting instance to ERROR state. 2014-10-09 11:04:34.011 19829 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on
192.168.2.166:5672 2014-10-09 11:13:14.985 19829 INFO nova.scheduler.filter_scheduler [req-531418dc-fde2-440c-8fb5-7e7d57b108a3 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f 914a18] Attempting to build 1 instance(s) uuids: [u'57d92c9f-9cee-42cc-ab08-94749e790401'] 2014-10-09 11:13:15.011 19829 INFO nova.filters [req-531418dc-fde2-440c-8fb5-7e7d57b108a3 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f914a18] Filter Imag ePropertiesFilter returned 0 hosts 2014-10-10 08:52:17.811 5076 WARNING nova.scheduler.driver [req-d07d057a-7ce6-4154-96b8-7640a16d4ec9 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f914a18] [instance: fa245933-d55b-4f68-90ce-ee7ab1deb536] Setting instance to ERROR state. 2014-10-10 09:03:58.055 5076 INFO nova.openstack.common.service [-] Caught SIGTERM, exiting 2014-10-10 09:03:58.783 14967 INFO nova.openstack.common.periodic_task [-] Skipping periodic task
_periodic_update_dns because its interval is negative 2014-10-10 09:03:58.830 14967 AUDIT nova.service [-] Starting scheduler node (version
2014.1.2) 2014-10-10 09:03:59.382 14967 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on
192.168.2.166:5672 2014-10-10 09:04:17.220 14967 INFO nova.scheduler.filter_scheduler [req-f7e08c23-7689-4a1e-8184-99761e681c1b 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f 914a18] Attempting to build 1 instance(s) uuids: [u'e902fea6-9f30-450d-985d-9aca6f1e4e10'] 2014-10-10 09:04:17.254 14967 INFO nova.filters [req-f7e08c23-7689-4a1e-8184-99761e681c1b 3306d471e67c4735a2816fdc94ac9552 5dc1db60d64f46249e68a3498f914a18] Filter Imag ePropertiesFilter returned 0 ...
(more)
edit retag flag offensive close merge delete

Comments

I've many available compute nodes and all are having loads of resources available.

vishgarg gravatar imagevishgarg ( 2014-10-10 04:53:02 -0500 )edit

I tried to add this line in nova.conf on compute node but, when I restart the server this line again gets deleted. Should I then add this line?

vishgarg gravatar imagevishgarg ( 2014-10-10 04:58:16 -0500 )edit

please post the out put of this nova-manage service list

and send the nova-compute logs

Can you check this once service nova-compute restart
process is running or getting unknown instance?

RHK gravatar imageRHK ( 2014-10-10 05:08:03 -0500 )edit

nova-cert nodethreehcl internal enabled :-) 2014-10-10 10:11:08 nova-scheduler nodethreehcl internal enabled :-) 2014-10-10 10:11:07 nova-conductor nodethreehcl internal enabled :-

vishgarg gravatar imagevishgarg ( 2014-10-10 05:11:29 -0500 )edit

its showing all are working fine

vishgarg gravatar imagevishgarg ( 2014-10-10 05:11:48 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-10-10 04:59:37 -0500

vishgarg gravatar image

I've freshly deployed the new servers with loads of resources, openstack dashboard is showing them available too.

edit flag offensive delete link more
2

answered 2014-10-10 04:56:36 -0500

updated 2014-10-10 04:58:47 -0500

"No valid host found error" is raised when your compute nodes have not enough resources to lunch an instance. When you issue create instance command, the nova-scheduler looks for host to find the best host with enough resources you requested. But when no host found, this error will be raised, as probably in your case. Check your host available resources(RAM, CPU, Disk).

Also check your nova-scheduler log file.

edit flag offensive delete link more

Comments

I've also given the nova-scheduler.log in my question which is not showing much of the exact problem.

vishgarg gravatar imagevishgarg ( 2014-10-10 05:02:34 -0500 )edit

I've actually found the error in nova-schedular.log http://paste.ubuntu.com/8558753/ can you please check this out and help me.

vishgarg gravatar imagevishgarg ( 2014-10-14 07:08:29 -0500 )edit
0

answered 2014-10-10 04:49:25 -0500

RHK gravatar image

updated 2014-10-10 04:56:12 -0500

Check the resource availability in compute node. Once restart the nova services in controller and compute, also please ensure nova-compute service is active or not and check the flag scheduler_default_filters=AllHostsFilter in nova.conf

Regards,
RHK

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-10 04:30:49 -0500

Seen: 5,688 times

Last updated: Oct 10 '14