Ask Your Question
0

Installing Juno in centos 7 [closed]

asked 2014-10-08 07:43:07 -0500

rahulrajvn gravatar image

Have any one tried to install Juno in centos7. The centos7 comes with a python 2.7 version and while I am installing the openstack services I am getting dependency issues as shown below.

--> Finished Dependency Resolution
Error: Package: python-oslo-messaging-1.4.0.0-4.el7.centos.noarch (openstack-juno)
           Requires: python-qpid
Error: Package: python-crypto2.6-2.6.1-1.el6.x86_64 (epel)
           Requires: libgmp.so.3()(64bit)
Error: Package: python-oauthlib-0.6.0-4.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-iso8601-0.1.10-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-crypto2.6-2.6.1-1.el6.x86_64 (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-jsonschema-2.3.0-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-dogpile-cache-0.5.4-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-passlib-1.5.3-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-kombu-1.1.3-2.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-posix_ipc-0.9.8-1.el6.x86_64 (epel)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: python-posix_ipc-0.9.8-1.el6.x86_64 (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-anyjson-0.3.3-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-dogpile-core-0.4.1-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-crypto2.6-2.6.1-1.el6.x86_64 (epel)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: python-keystone-2014.2-0.4.b3.el7.centos.noarch (openstack-juno)
           Requires: python-paste-deploy >= 1.5.0
Error: Package: python-keystone-2014.2-0.4.b3.el7.centos.noarch (openstack-juno)
           Requires: python-routes >= 1.12
Error: Package: python-keyring-0.7-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Have any one faced such issue.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by rahulrajvn
close date 2014-10-09 05:18:00.514168

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-10-08 08:03:03 -0500

dbaxps gravatar image

Install works . View http://cloudssky.com/en/blog/RDO-Open... .
Looks like you have to remove EPEL.

edit flag offensive delete link more

Comments

I tried removing the epel repo but that lead to another dependency error as below. And I am trying to to install using the URL http://docs.openstack.org/trunk/insta... .

ERROR:http://paste.openstack.org/show/119624/

rahulrajvn gravatar imagerahulrajvn ( 2014-10-08 08:19:50 -0500 )edit

I would try to set up EPEL 7 http://www.cyberciti.biz/faq/installi...

dbaxps gravatar imagedbaxps ( 2014-10-08 08:36:12 -0500 )edit

Ok. Let me try.

rahulrajvn gravatar imagerahulrajvn ( 2014-10-08 08:37:19 -0500 )edit

The issue has been fixed. I started the restarted the installation with a brand new centos7 minimal installation and with epel 7 repo and now its not showing any error.

rahulrajvn gravatar imagerahulrajvn ( 2014-10-09 05:17:31 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-08 07:43:07 -0500

Seen: 3,253 times

Last updated: Oct 08 '14