Ask Your Question
0

Set up devstack with two ethernet interfaces

asked 2014-10-03 10:59:58 -0500

capzulu gravatar image

updated 2014-10-06 13:21:20 -0500

I'm trying to setup a devstack VM using virt-manager. The VM must have two interfaces: 1 interface to internet (eth0) and 1 interface to connect to another physical machine (eth1). I setup this at my local.conf:

[[local|localrc]]

DEST=/opt/stack

FLAT_INTERFACE=eth0

# Passwords and token
ADMIN_PASSWORD=admin
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

# Fixed and floating subnets
FIXED_RANGE=10.100.27.0/24
#FLOATING_RANGE=192.168.200.0/24
NETWORK_GATEWAY=10.100.27.1
PUBLIC_NETWORK_GATEWAY=172.24.4.225
Q_FLOATING_ALLOCATION_POOL=start=172.24.4.226,end=172.24.4.231

# Reclone each time
RECLONE=yes

# Disable Nova Networking
disable_service n-net

# Neutron - Networking Service
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service q-metering
enable_service neutron

# Neutron - VPN as a Service
enable_service q-vpn

Q_PLUGIN=ml2
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=flat,vlan
ML2_VLAN_RANGES=physnet0:2000:2999,physnet1:3000:3999
ENABLE_TENANT_VLANS=True
PHYSICAL_NETWORK=physnet0
OVS_PHYSICAL_BRIDGE=br-eth0
OVS_BRIDGE_MAPPINGS=physnet0:br-eth0,physnet1:br-eth1

The devstack buildss successfuly. The instances created in openstack have internet communication. I then create a provider network that maps with physnet1:

neutron net-create provider --shared --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 3500

And create a subnet:

neutron subnet-create --name provider_subnet provider 10.100.28.0/24

I launch a VM and a router in this new network and they ping each other. Then I add eth1 to br-eth1 with:

ovs-vsctl add-br br-eth1 eth1

So that network maps in the eth1 interface. Then I connect a physical machine to eth1 with a network cable and set the the vlan ID 3500 for the interface. When I try to ping from the physical machine to the router or the VM inside devstack I don't get communication.

Is there any missing configuration in devstack local.conf?

Thank you

edit retag flag offensive close merge delete

Comments

Not to be silly, but is there an indication that the link between the machines is functional? For one thing, do the interfaces have the LINK light on?

Suggestion: install Wireshark (or some other packet sniffer) and check that communications is really occurring at layer 2.

Beel gravatar imageBeel ( 2014-10-07 02:11:45 -0500 )edit

I installed Wireshark and checked that when I ping from the physical machine to the router/ VM inside devstack there is an ARP communication (request and reply) and my physical machine stores the MAC address inside the arp table. But the ICMP PING or other kind of communication, doesn't get through

capzulu gravatar imagecapzulu ( 2014-10-13 07:20:09 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-10-07 04:38:03 -0500

SGPJ gravatar image

Please refer to this guide: https://github.com/osrg/ryu/wiki/RYU-...

edit flag offensive delete link more

Comments

I guess that this problem is regarding communication with VLAN and your guide doesn't cover that.

capzulu gravatar imagecapzulu ( 2014-10-13 07:22:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-03 10:57:11 -0500

Seen: 2,778 times

Last updated: Oct 07 '14