Ask Your Question
0

how does one specify network id with nova boot command line?

asked 2014-10-02 12:53:16 -0500

RedCricket gravatar image

updated 2014-10-02 12:54:07 -0500

Hi,

Here is my problem. When I attempt to create an instance like so ...

[root@stack-mgmt4 ~]# nova boot --flavor 1 --image Cirros rbc-test

... I get this error message:

ERROR: Multiple possible networks found, use a Network ID to be more specific. (HTTP 400) (Request-ID: req-...)
[root@stack-mgmt4 ~]# neutron net-list
+--------------------------------------+-------------------------------+-------------------------------------------------------+
| id                                   | name                          | subnets                                               |
+--------------------------------------+-------------------------------+-------------------------------------------------------+
| dbfdd1e2-bc4a-46ab-8ddc-b4206a59ec20 | ... | ... |
| 1d2e7c15-a40f-4b4b-b891-b97cbdfd7629 | ... |... |
+--------------------------------------+-------------------------------+-------------------------------------------------------+

So I try and specify the "Network ID" like so ...

[root@stack-mgmt4 ~]# nova boot --net-id "dbfdd1e2-bc4a-46ab-8ddc-b4206a59ec20" --flavor 1 --image Cirros rbc-test

... but I get a usage error:

usage: nova [--version] [--debug] [--os-cache] [--timings]
            [--timeout <seconds>] [--os-username <auth-user-name>]
            [--os-password <auth-password>]
            [--os-tenant-name <auth-tenant-name>]
            [--os-tenant-id <auth-tenant-id>] [--os-auth-url <auth-url>]
            [--os-region-name <region-name>] [--os-auth-system <auth-system>]
            [--service-type <service-type>] [--service-name <service-name>]
            [--volume-service-name <volume-service-name>]
            [--endpoint-type <endpoint-type>]
            [--os-compute-api-version <compute-api-ver>]
            [--os-cacert <ca-certificate>] [--insecure]
            [--bypass-url <bypass-url>]
            <subcommand> ...
error: unrecognized arguments: --net-id rbc-test
Try 'nova help ' for more information.

So how does one specify the network id?

Thanks

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-10-02 13:23:06 -0500

RedCricket gravatar image

Never mind ... doing a nova help boot lead me to this command line

nova boot --nic net-id=dbfdd1e2-bc4a-46ab-8ddc-b4206a59ec20 --flavor 1 --image Cirros rbc-test
edit flag offensive delete link more

Comments

@RedCricket : Thanks for the explanation it worked for me . :)

gkadam gravatar imagegkadam ( 2015-12-27 23:25:20 -0500 )edit
0

answered 2016-02-14 19:06:25 -0500

Thanks a lot for the tip, faced the same issue and struggled quiete a lot until I came across this post

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-02 12:53:16 -0500

Seen: 15,652 times

Last updated: Oct 02 '14