Ask Your Question
1

demo-router not pingable from external network (a promiscuous mode problem)

asked 2014-10-02 04:04:21 -0500

jazzsir gravatar image

updated 2014-10-03 20:17:02 -0500

I have followed the Icehouse doc "OpenStack Installation Guide(three-node)". My environment is same as the doc except IP and nodes that are builded as VM using libvirt(qemu/KVM) in CentOS 6.5 as below image description

I can not ping floating IP of demo-router from external node in this stage -> http://docs.openstack.org/icehouse/in...

I think this problem is related to promiscuous mode. Because, I can capture "ARP request" and "ICMP echo request" in ① and ② interfaces in the picture above, but in ③, I can only capture "ARP request" packets.

why are "ICMP echo request"s blocked after ②.

I have set..

  1. ①, ② and ③ are set into promiscuous mode using "ip link set [INTERFACE_NAME] promisc on"
  2. ICMP and TCP are enabled in "nova secgroup"
  3. MAC addresses of both side are updated on each ARP table.

I have found a post in same situation I am in -> https://ask.openstack.org/en/question... but I don't understand a way of solution in that post

Any hints would be much appreciated!.

edit retag flag offensive close merge delete

Comments

SGPJ gravatar imageSGPJ ( 2014-10-02 04:27:31 -0500 )edit

hi SGPJ, I could not find something to solve this problem in the post. I am looking for a way to get IP packets as well as ARP packets on "eth1" in VM3 in the picture on my post.

jazzsir gravatar imagejazzsir ( 2014-10-02 11:52:01 -0500 )edit

Hi Jazzsir, I have the same issue with Juno and Kilo, not sure if you have resolved the problem or not, if yes, would you please share your solution? Many thanks in advance!

unitiger gravatar imageunitiger ( 2015-07-27 23:35:14 -0500 )edit

I guess this problem was related to virt_type http://docs.openstack.org/juno/config.... But I haven't tried..

jazzsir gravatar imagejazzsir ( 2016-04-17 09:29:41 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-02-08 01:12:56 -0500

Pankaj Saraf gravatar image

Please enable the promiscuous mode from the virtual machine security configuration in case of using vmware. Running from command line will not help. Please do it from ESX vcenter client dashboard.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-10-02 04:04:21 -0500

Seen: 587 times

Last updated: Oct 03 '14