Ask Your Question
0

Install Openstack error

asked 2014-10-01 02:05:27 -0500

jokohp gravatar image

Dear All, I try to install openstack using centos 6.5 and from documentation http://docs.openstack.org/icehouse/install-guide/install/yum/openstack-install-guide-yum-icehouse.pdf (http://docs.openstack.org/icehouse/in...) When i want to install the keystone, it was error when doing:

[root@controller ~]# su -s /bin/sh -c "keystone-manage db_sync" keystone Traceback (most recent call last): File "/usr/bin/keystone-manage", line 37, in <module> from keystone import cli File "/usr/lib/python2.6/site-packages/keystone/cli.py", line 21, in <module> from keystone.common import openssl File "/usr/lib/python2.6/site-packages/keystone/common/openssl.py", line 18, in <module> from keystone.common import environment File "/usr/lib/python2.6/site-packages/keystone/common/environment/__init__.py", line 20, in <module> from keystone.openstack.common import log File "/usr/lib/python2.6/site-packages/keystone/openstack/common/log.py", line 435, in <module> class LogConfigError(Exception): File "/usr/lib/python2.6/site-packages/keystone/openstack/common/log.py", line 437, in LogConfigError message = _('Error loading logging config %(log_config)s: %(err_msg)s') File "/usr/lib/python2.6/site-packages/keystone/openstack/common/gettextutils.py", line 68, in _ return Message(msg, domain='keystone') File "/usr/lib/python2.6/site-packages/keystone/openstack/common/gettextutils.py", line 168, in __new__ msgtext = Message._translate_msgid(msgid, domain) File "/usr/lib/python2.6/site-packages/keystone/openstack/common/gettextutils.py", line 207, in _translate_msgid system_locale = locale.getdefaultlocale() File "/usr/lib64/python2.6/locale.py", line 478, in getdefaultlocale return _parse_localename(localename) File "/usr/lib64/python2.6/locale.py", line 410, in _parse_localename raise ValueError, 'unknown locale: %s' % localename ValueError: unknown locale: UTF-8

Please help how to troubleshoot this.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-10-01 05:54:09 -0500

You can change LC_ALL local variable to force every applications use your enforced language:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

Or try this one:

export LC_ALL="en_GB.utf8"

Hint: Be cautious for every applications on your system(If existed) that use languages other than what you prompt by setting LC_ALL variable(e.g. chines, ...).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-10-01 02:03:42 -0500

Seen: 916 times

Last updated: Oct 01 '14