How to use public IPS from a different switch with legacy networking?

asked 2014-09-30 17:47:01 -0600

questionmorc gravatar image

Hello,

Im setting up Icehouse on Ubuntu 14.04.

As of right now I have everything working as per this guide. http://docs.openstack.org/icehouse/in...

Using the two node architecture with legacy networking. I can launch an instance and connect to it using the console and access the internet from within the instance.

this is my /etc/network/interfaces on my compute node:

auto eth0
iface eth0 inet static
        address 192.168.2.181
        netmask 255.255.255.0
        gateway 192.168.2.1
    dns-nameservers 8.8.8.8 8.8.4.4

auto eth1
iface eth1 inet manual
        up ip link set dev $IFACE up
        down ip link set dev $IFACE down

Now we have a block of public IP addresses given to us by our ISP. I want to be able to attach these to my instances via floating IP's so for eth0 I have it plugged into the switch for the internal network (192.168.2.1) And in eth1 I plugged it into my public IP switch.

On my compute node i do: nova-manage floating create --pool nova --ip_range XXX.XXX.XXX.XXX/29 --interface eth1

Now when I attach it to my instance it says that it has been assigned that IP.

However now inside the instance I cannot connect to the internet and I cannot connect to the instance remotely using the floating IP that was just assigned.

Here is my /etc/nova/nova.conf :

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = c459da16ef8826818b7f
auth_strategy = keystone

my_ip = 192.168.2.181
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 192.168.2.181
novncproxy_base_url = http://controller:6080/vnc_auto.html

glance_host = controller
network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = True
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth1
public_interface = eth0

[database]
connection: mysql://nova:5940c7703a1c0f7396a1@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = 5940c7703a1c0f7396a1

Can someone help me find where I am going wrong?

edit retag flag offensive close merge delete

Comments

1

Are you launching instances attached to that network or are you launching instances attached to the private network and then attaching the Floating IP to it after? If you are just attaching to the Public network then you probably don't have DHCP setup or DNS.

mpetason gravatar imagempetason ( 2014-10-01 10:55:21 -0600 )edit

Im launching the instance attached to a private network and then attaching the floating IP. I followed this example for my private network http://docs.openstack.org/icehouse/in... .

questionmorc gravatar imagequestionmorc ( 2014-10-01 11:40:48 -0600 )edit
1

You may still need to modify the security groups you have configured. I would setup All ICMP/UDP/TCP and allow all traffic while troubleshooting.

mpetason gravatar imagempetason ( 2014-10-01 11:43:05 -0600 )edit

Security groups are open. The public switch is plugged into eth1 ... i tried changing the public_interface option to eth1 but the whole network loses connectivity when I do that. Am I right putting public_interface to eth1? If so any idea why it crashes the entire network when I switch it to that?

questionmorc gravatar imagequestionmorc ( 2014-10-01 12:56:46 -0600 )edit
1

I'll be honest, I have more experience with Neutron. We'll have to wait for another update on the question.

mpetason gravatar imagempetason ( 2014-10-01 12:59:32 -0600 )edit