Ask Your Question
1

Running the command glance image-list I get the error: finding address for http://controller:9292/v1/images/detail

asked 2014-09-30 14:16:35 -0600

marlonss gravatar image

In doing an initial install of OpenStack, with Ubuntu 14.07 and get the error described. Thank you for your help !

edit retag flag offensive close merge delete

Comments

It sounds like you have a basic name resolution problem. If you think it is more than that, please update your question with the exact command you are running and the exact output you see, and include output that shows the hostname of your controll resolving correctly. Thanks!

larsks gravatar imagelarsks ( 2014-09-30 15:30:58 -0600 )edit

The command worked a few days ago - not sure what changed but here are more details:

glance image-list

Error finding address for http://controller:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20 (http://controller:9292/v1/images/deta...) : HTTPConnectionPool(host='controller', port=9292): Max retries exceeded with url: /v1/

marlonss gravatar imagemarlonss ( 2014-09-30 16:25:03 -0600 )edit

Command I was trying to run was: glance image-list

Just to show the name "controller" can be found: # netstat | grep controller tcp 0 0 controller:mysql controller:35830 ESTABLISHED tcp 0 0 controller:35830 controller:mysql

marlonss gravatar imagemarlonss ( 2014-09-30 16:30:21 -0600 )edit

Looks like you cannot resolve the hostname "controller" to an IP address. Add the line "IP_ADDRESS_OF_THE_CONTROLLER controller" to your "/etc/hosts" file and try it again.

Christian Berendt gravatar imageChristian Berendt ( 2014-09-30 23:42:29 -0600 )edit

Here is my hosts file: Controller name found but not the port 9292

cat /etc/hosts

#127.0.0.1 localhost #127.0.1.1 raid03 128.6.57.128 xxid03.xxx.xxx.xxx
10.255.255.255 broadcasthost 255.255.255.255 broadcasthost #

OpenStack Configuration

OpenStack

10.0.0.11 controller

OpenStack

10.0.0.31 compute1

marlonss gravatar imagemarlonss ( 2014-10-01 09:36:11 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-10-06 16:29:33 -0600

marlonss gravatar image

updated 2014-10-09 13:27:02 -0600

Problem resolved by changing the permission on a glance library file.

Re-installed the database and keystone being careful to follow the documentation when run commands as root and when to run commands as a regular user.

Do not do the database commands as root because this will cause permission problems later now that are difficult to resolve.

Thank you to those who tired to help - hope this post helps someone else.

edit flag offensive delete link more

Comments

How do you change permission on a glance library file?

sunzen.wang gravatar imagesunzen.wang ( 2016-04-15 03:41:15 -0600 )edit

now i had done what you posted,if there have some skill to solve this problem without re-installing?

Yuji gravatar imageYuji ( 2016-09-05 01:29:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-30 14:16:35 -0600

Seen: 4,788 times

Last updated: Oct 09 '14