Ask Your Question
2

Instances on different machines can't resolve each other's names

asked 2013-09-12 09:16:58 -0500

jbradfield gravatar image

I have Openstack running on a group of five machines. If I spin up a bunch of instances, the ones that spawn on the same machine can ping each other with their instance names, but instances on different machines can only ping each other with their IP address.

e.g. say my instances look like this:

Host     Name    IP Address
blade1   node1   11.11.0.4
blade1   node2   11.11.0.5
blade2   node3   11.11.0.6

Then I get the following results:

ubuntu@node1:~$ host node2
node2.novalocal has address 11.11.0.5
ubuntu@node1:~$ host node3
Host node3 not found: 3 (NXDOMAIN)
ubuntu@node1:~$ ping 11.11.0.6
PING 11.11.0.6 (11.11.0.6) 56(84) bytes of data.
64 bytes from 11.11.0.6: icmp_req=1 ttl=64 time=1.38 ms

etc. Similarly, node3 can't resolve the names of either of the instances on blade1, but can still ping them by address. Is there a way resolve instance names regardless of what machine they spawn on?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-09-29 13:11:28 -0500

Goran M gravatar image

looks like a local DNS issue, but you didn't put enough details for troubleshooting:

  • Can you post the content of /etc/resolv.conf from the instances?

  • Do you use DHCP or static IP on the instances?

  • Do you use dnsmasq on the Neutron(network controller) node and what is the config on it?

  • what is the output of "neutron subnet-show [subnet id for the instances]" on the network controller?

  • Do you use any other DNS/DHCP server in the tenant or in that network?

In general, your /etc/resolv.conf should have something like:

search openstacklocal
nameserver 10.0.0.3

and your Neutron node should have dnsmasq process running with something like:

dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-19943446-d4 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/f6868d79-2a50-4d6b-a70e-0b9055e23927/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/f6868d79-2a50-4d6b-a70e-0b9055e23927/host --addn-hosts=/var/lib/neutron/dhcp/f6868d79-2a50-4d6b-a70e-0b9055e23927/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/f6868d79-2a50-4d6b-a70e-0b9055e23927/opts --leasefile-ro --dhcp-authoritative --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=65536 --conf-file= --domain=openstacklocal --dhcp-broadcast

...assuming your network controller has IP of 10.0.0.3 and you use the default Openstack (Juno) DHCP settings.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-12 09:16:58 -0500

Seen: 865 times

Last updated: Sep 29 '15