Ask Your Question
0

Not able to ssh VMs on compute node (instance console is also not available on horizon)

asked 2014-09-30 01:26:50 -0500

shalini-khandelwal gravatar image

I am not able to ping or ssh my instances present on compute node as well as getting error on console on horizon for the same. VMs on controller node are accessible through controller node only but not through compute node. Vms on both hosts have same security group and ssh and ping enabled.

Machine and installation details:

I have multi node devstack installation in my system:

   MACHINE 1 (controller node): 12GB RAM (devstack installed openstack with following local.conf:

[[local|localrc]]

DEST=/opt/stack

enable_service s-proxy s-object s-container s-account

SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5

SWIFT_REPLICAS=1

SWIFT_DATA_DIR=$DEST/data/swift enable_service n-net q-svc q-agt q-dhcp q-l3 q-meta q-metering

LOGDAYS=1

LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOGDIR=$DEST/logs/screen ADMIN_PASSWORD=quiet DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50 PUBLIC_INTERFACE=eth0

MACHINE 2 (Compute node): 4GB RAM (devstack installed compute with following local.conf)

[[local|localrc]]

DEST=/opt/stack LOGDAYS=1 VERBOSE=True LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOGDIR=$DEST/logs/screen ADMIN_PASSWORD=quiet DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

PUBLIC_INTERFACE=eth0

HOST_IP=10.201.1.3 SERVICE_HOST=10.201.2.58 Q_HOST=$SERVICE_HOST

disable_all_services enable_service neutron n-cpu rabbit q-api q-agt

I have one NIC in both machines with eth0 interface

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-09-30 22:14:56 -0500

SGPJ gravatar image

You should have 2nd interface eth1 which will be data network between nodes.

edit flag offensive delete link more

Comments

I need to have second interface in both machines? Do i need to configure its IP in some configuration file. As done for eth0 in local.conf?

shalini-khandelwal gravatar imageshalini-khandelwal ( 2014-10-01 00:31:10 -0500 )edit
SGPJ gravatar imageSGPJ ( 2014-10-01 01:55:28 -0500 )edit
0

answered 2014-10-01 02:56:23 -0500

nd gravatar image

The setup should still work with only one interface also [which will be used to access the dashboard as well as which will be connected to your br-tun tunnel on both controller and compute nodes for communication between the VMs/instances hosted across the two nodes - if you are using neutron, or assigned to br100 bridge if you are using Flat networking with nova network]. However, with only one NIC - what you will NOT be able to achieve is being able to assign floating IP address - if you want this only then you will definitely need one more NIC. Can you show the output of ovs-vsctl show from both nodes?

nd

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-30 01:21:07 -0500

Seen: 1,161 times

Last updated: Sep 30 '14