Ask Your Question
0

Image service problem, Could not find user: admin (HTTP 401)

asked 2013-09-11 22:41:44 -0500

Andy gravatar image

Hi everyone, I have followed the document of OPENSTACK BASIC INSTALLATION GUIDE FOR UBUNTU 12.04 (LTS) AND DEBIAN WHEEZY http://docs.openstack.org/grizzly/basic-install/apt/content/basic-install_controller.html

I am doing the OpenStack Image Service section.

after I download img from wget http://uec-images.ubuntu.com/releases/12.04.2/release/ubuntu-12.04.2-server-cloudimg-amd64-disk1.img then I do this: $ glance image-create --is-public true --disk-format qcow2 --container-format bare --name "Ubuntu" < ubuntu-12.04.2-server-cloudimg-amd64-disk1.img

it shows Could not find user: admin (HTTP 401)

how can I solve this problem?

many thanks

Andy

edit retag flag offensive close delete

Comments

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-11 23:14:29 -0500

howzer gravatar image

After Keystone, you will need to make sure the service is running and you have populated the database with the required tables (keystone-manage db_sync). You will need to create initial users from the script in the documentation, which will add the "admin" user:

ADMIN_USER=$(keystone user-create --name=admin --pass="$ADMIN_PASSWORD" --email=admin@domain.com | grep " id " | get_field 2)

You can quickly verify if the user exists in the database by opening mysql then selecting the 'keystone' database, querying the user table. If, of course, you have already done this; check your glance configuration for the proper sql_connection connection.

edit flag offensive delete publish link more

Comments

Hi Thanks for your reply. 1. How do I make sure the service is running? 2. I did keystone-manage db_sync. 3. How do I create initial users from the script in the documentation?

Andy ( 2013-09-12 00:58:21 -0500 )edit
0

answered 2013-09-12 00:59:33 -0500

Andy gravatar image

4. I did=>ADMIN_USER=$(keystone user-create --name=admin --pass="$ADMIN_PASSWORD" --email=admin@domain.com | grep " id " | get_field 2) it shows: get_field: command not found Conflict occurred attempting to store user. (1062, "Duplicate entry 'default-admin' for key 'domain_id'") (HTTP 409) Thanks a lot

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
2 followers

Stats

Asked: 2013-09-11 22:41:44 -0500

Seen: 438 times

Last updated: Sep 11 '13