Ask Your Question
2

Which provider:network_type to use when creating external network with GRE network? [closed]

asked 2013-09-10 21:15:09 -0500

spcla1 gravatar image

Configuration:
Ubuntu 12.04 (1 controller node, 1 network node, 1 compute node) / GRE Tunneling / Per-tenant Routers with Private Networks

Got a little bit confused with the Openstack manual, when creating an external network using GRE with "Per-tenant Routers with Private Networks". I created it using "provider:network_type gre" but in the Openstack manual sample configuration, it was created using "provider:network_type local". I thought "provider:network_type local" is only use for single machine, does local also need to be used with " Per-tenant Routers with Private Networks"?

I also noticed that the external subnet was created with enable_dhcp=true. Doesn't it need to be false with external subnet?

Please help. Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by spcla1
close date 2014-03-06 19:14:22.311416

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-09-13 05:48:53 -0500

darragh-oreilly gravatar image

updated 2013-09-13 08:45:07 -0500

Quantum networks with router:external=true are external networks and are treated differently than internal networks. Some attribute values have no meaning for external networks/subnets and don't have much effect (but I'm not sure if they have zero effect). So yeah, it's confusing.

When using the Grizzly OVS plugin with a dedicated bridge for the external network (named br-ex by default), you should use provider:network_type=local as the doc says. But using type GRE seems to work as you found - I think the OVS L2 plugin agent just doesn't try to manage the ports created by the l3-agent because they are not on br-int.

Also to add to the confusion, it seems that it's possible to use provider networks for external networks instead of a dedicated br-ex. So the provider:network_type vlan or flat would have to be specified. This will probably be the way in future versions.

Yes, you should set enable_dhcp=false for external subnets, but again I'm not sure if it has any effect if you don't.

edit flag offensive delete link more

Comments

Thanks you so much! You are always very helpful.

spcla1 gravatar imagespcla1 ( 2013-09-13 09:35:54 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-10 21:15:09 -0500

Seen: 1,828 times

Last updated: Sep 13 '13