cannot ssh into devstack host vm

asked 2013-09-10 14:08:36 -0500

dathomir gravatar image

I have a ubuntu-12.04.2-server-amd64.iso based vm hosted at on a vSphere ESX server. I installed openstack with the devstack on this vm. Everything went fine. I can ping out and ssh to machines on my vpn from, but I cannot ssh to it from other machines. I created users admin and kbroughton on the devstack host using the vmware console.

[laptop]$ ssh kbroughton@
kbroughton@'s password: 
Permission denied, please try again. 
Permission denied (publickey,gssapi-with-mic,password).

I also tried stack and admin@ , but that doesn't have an ssh.

password didn't work, so i tried to set up passwordless

Using scp i copied my laptop id_rsa for kbroughton to /home/kbroughton/.ssh/authorized_keys

made the following changes to /etc/ssh/sshd_config

# explicitly allow users
AllowUsers kbroughton stack admin
# uncommented this
AuthorizedKeysFile %h/.ssh/authorized_keys 

sudo service ssh restart

double checked that openssh-server is installed and running. Of course they are.

What am i missing

edit retag flag offensive close merge delete


id_rsa would normally be the private key file. You should really only copy your public key file to the remote machine's authorized_keys.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-13 06:10:20 -0500 )edit

1 answer

Sort by » oldest newest most voted

answered 2013-09-10 15:08:56 -0500

dathomir gravatar image

Answering my own question:

iptables was blocking ssh into the host. So, on the host machine.

iptables -N SSH       # this creates a rule of name SSH
iptables -I INPUT -s 0/0 -p tcp --dport 22 -j SSH
iptables -I SSH -s 0/0 -j ACCEPT

Then make it permanent

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-09-10 14:08:36 -0500

Seen: 1,637 times

Last updated: Sep 10 '13