Ask Your Question
0

Not able to ping or SSH to the instances from the router name space. But instance can ping the router.

asked 2014-09-27 11:30:40 -0500

rvarghese gravatar image

updated 2014-09-27 11:34:02 -0500

dbaxps gravatar image

Hello,

I have created a 3 node icehouse setup with GRE. The issue now I am facing is the instance is not reachable through ping or ssh from the router or dhcp name spaces. But the instance can ping the router and also the other instances in the same subnet. Please see the details below.

root@network:~# neutron net-list
+--------------------------------------+------+-------------------------------------------------------+
| id                                   | name | subnets                                               |
+--------------------------------------+------+-------------------------------------------------------+
| f94dc5db-49f0-4383-86c2-1c1cce2a22bc | demo | 867be7d4-7a4e-4f4b-8081-f69cc029bd40 192.168.200.0/24 |
+--------------------------------------+------+-------------------------------------------------------+
root@network:~# neutron router-list
+--------------------------------------+------+-----------------------+
| id                                   | name | external_gateway_info |
+--------------------------------------+------+-----------------------+
| 9b494f49-a408-4cf4-b198-003344a776a2 | demo | null                  |
+--------------------------------------+------+-----------------------+
root@network:~# neutron router-port-list demo
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| dc32a946-81d2-4df8-918e-c8181e06cc6a |      | fa:16:3e:8a:71:63 | {"subnet_id": "867be7d4-7a4e-4f4b-8081-f69cc029bd40", "ip_address": "192.168.200.1"} |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+


root@network:~# ip netns list
qdhcp-f94dc5db-49f0-4383-86c2-1c1cce2a22bc
qrouter-9b494f49-a408-4cf4-b198-003344a776a2
root@network:~# ip netns exec qrouter-9b494f49-a408-4cf4-b198-003344a776a2 ping 192.168.200.1
PING 192.168.200.1 (192.168.200.1) 56(84) bytes of data.
64 bytes from 192.168.200.1: icmp_seq=1 ttl=64 time=0.125 ms

root@network:~# ip netns exec qrouter-9b494f49-a408-4cf4-b198-003344a776a2 ping 192.168.200.3
PING 192.168.200.3 (192.168.200.3) 56(84) bytes of data.
64 bytes from 192.168.200.3: icmp_seq=1 ttl=64 time=0.829 ms

root@network:~# ip netns exec qrouter-9b494f49-a408-4cf4-b198-003344a776a2 ping 192.168.200.2
PING 192.168.200.2 (192.168.200.2) 56(84) bytes of data.
2 packets transmitted, 0 received, 100% packet loss, time 1001ms

root@network:~# ip netns exec qrouter-9b494f49-a408-4cf4-b198-003344a776a2 ping 192.168.200.4
PING 192.168.200.4 (192.168.200.4) 56(84) bytes of data.
1 packets transmitted, 0 received, 100% packet loss, time 0ms

Thanks R

edit retag flag offensive close merge delete

Comments

What is MTU inside instance ?

dbaxps gravatar imagedbaxps ( 2014-09-27 12:37:47 -0500 )edit

VM instance MTU is 1500.

rvarghese gravatar imagervarghese ( 2014-09-28 21:13:58 -0500 )edit

Changing MTU doesn't work. Any other hits appreciated.

rvarghese gravatar imagervarghese ( 2014-09-29 07:50:50 -0500 )edit

Just want to add - I am able to reach the internet from the instance by adding a route on the qrouter namespace. Still not able to connect to the instance through ssh or ping

I can see some arp request on the TAP interface of the network node. But I think not all the icmp request packets are reachi

rvarghese gravatar imagervarghese ( 2014-09-29 12:28:13 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-10-04 20:34:19 -0500

rvarghese gravatar image

My Bad, it was just the security rules. Thanks for the hints. SSH was hanging, which was resolved by changing mtu to 1454.

edit flag offensive delete link more
0

answered 2014-09-28 23:01:05 -0500

dbaxps gravatar image

Try MTU=1454

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-27 11:30:40 -0500

Seen: 1,900 times

Last updated: Oct 04 '14