Ask Your Question
3

OpenStack Juno using RDO fails installation: AMQP server closed the connection

asked 2014-09-24 08:01:59 -0600

Thomas Chacko gravatar image

updated 2014-09-26 14:56:45 -0600

smaffulli gravatar image

Ventured trying out Openstack Juno install using the info on http://docs.openstack.org/trunk/insta...

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log --

192.168.0.20_api_nova.pp:                            [ DONE ]       
Applying 192.168.0.20_nova.pp
192.168.0.20_nova.pp:                             [ ERROR ]     
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp
Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log -------------

 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

I rechecked the nova-compute logs and they have the same error message :

2014-09-24 18:23:32.060 9594 ERROR oslo.messaging._drivers.impl_rabbit [req-1b152ce0-6298-487a-b6cc-149024692b34 ] AMQP server 192.168.0.20:5672 closed the connection. Check login
edit retag flag offensive close merge delete

Comments

The packstack error was for the nova-compute service. Why did you include logs for nova-consoleauth and nova-cert?

larsks gravatar imagelarsks ( 2014-09-24 09:46:07 -0600 )edit

Do the logs for your rabbitmq service show any useful error messages?

larsks gravatar imagelarsks ( 2014-09-26 21:20:13 -0600 )edit

=ERROR REPORT==== 28-Sep-2014::11:39:35 === closing AMQP connection <0.664.0> (192.168.0.20:37420 -> 192.168.0.20:5672): {handshake_error,starting,0, {amqp_error,access_refused, "AMQPLAIN login refused: user 'guest' can only connect via localhost",

Thomas Chacko gravatar imageThomas Chacko ( 2014-09-28 08:20:36 -0600 )edit

Hi,

I just hit this error with "--install-hosts=$IP1,$IP2,$IP3" - I don't know what host it was installing at the time (I assume the controller node, $IP1).

Now that I've had the error, how can I get past it?

Thanks, Dave.

Dave Neary gravatar imageDave Neary ( 2014-12-03 17:19:13 -0600 )edit

Dave, I filed a bug about this issue: https://bugzilla.redhat.com/show_bug.cgi?id=1175428 (https://bugzilla.redhat.com/show_bug....)

rwmjones gravatar imagerwmjones ( 2014-12-17 12:27:54 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-29 13:06:10 -0600

Thomas Chacko gravatar image

updated 2014-09-30 23:05:34 -0600

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

    [
      {rabbit, [
        {default_user, <<"guest">>},
        {default_pass, <<"guest">>}
      ]},
      {kernel, [
      ]}
    ].

% EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use-epel=y
...
...
(wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started . 

// Then on another term window, manually stop the MQ service,
$  sudo service rabbitmq-server stop

//  overwrite the /etc/rabbitmq/rabbitmq.config file with the below config :
[{rabbit, [{loopback_users, []}]}].
% EOF

// and restart the service 
$  sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use-epel=y ) or answer-file option.

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

edit flag offensive delete link more

Comments

On system restarts, the neutron server cannot connect to the MQ and Sql . Require manual service restart for it to work. existing bug ? https://bugzilla.redhat.com/show_bug....

Thomas Chacko gravatar imageThomas Chacko ( 2014-09-30 06:33:39 -0600 )edit

I'm not a fan of this solution - updating a Puppet managed file is a recipe for disaster the next time it gets run. Is there a better way around the issue?

Dave Neary gravatar imageDave Neary ( 2014-12-03 18:20:03 -0600 )edit

Me too - this was a workaround solution. The new RDO packstack script for Juno resolved this bug with AMQP and Rabbit MQ start-up issue among others. I checked it out and it works fine.

Thomas Chacko gravatar imageThomas Chacko ( 2014-12-04 22:15:10 -0600 )edit

Thanks - turn out my issue was different - I was installing into OpenStack instances, and the security group rules were preventing AMQP traffic from getting through.

Dave Neary gravatar imageDave Neary ( 2014-12-05 06:39:24 -0600 )edit
0

answered 2016-05-09 15:10:21 -0600

6543217890meh gravatar image

Not being a fan of using the guest/guest account. I found that moving the Rabbit Host/User/Pass information to the [DEFAULT] section of my .conf file, allowed me to use a real username and password. This also solved my issue of my instance trying to using localhost:5672.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-24 08:01:59 -0600

Seen: 15,599 times

Last updated: May 09 '16