Ask Your Question
0

instances do not receive incoming traffic (no internet)

asked 2014-09-19 08:28:01 -0500

kaaaas54 gravatar image

Hello there,

im now setting up openstack on a two-node cluster for days and encountered several problems. My current issue is that my launched instances have no internet connection. This is my setup:

2 Nodes

  1. Controller Node (one NIC, static ip: 192.168.0.100, keystone, swift, glance, ...)
  2. Compute Node (one NIC, static ip: 192.168.0.101, nova-compute, nova-network)

I am using nova-network (not neutron). I am able to launch an instance which gets a IP via DHCP. I can connect to the instance via SSH and I am able to ping to compute node from the instance, but I am not able to reach any server on the internet.

This are are nova.conf file on the compute node:

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata

auth_strategy = keystone

rpc_backend = rabbit
rabbit_host = controller
rabbit_password = ***

my_ip = 192.168.0.101
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 192.168.0.101
novncproxy_base_url = http://controller:6080/vnc_auto.html

glance_host = controller

network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth0
public_interface = eth0

[database]
connection=mysql://nova:***@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = ***

ifconfig on Compute Node:

br100     Link encap:Ethernet  HWaddr 00:50:8d:b0:ee:23  
          inet addr:203.0.113.1  Bcast:203.0.113.255  Mask:255.255.255.0
          inet6 addr: fe80::8ba:ecff:fe5b:3cbe/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19528 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41778 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2316658 (2.3 MB)  TX bytes:9146269 (9.1 MB)

eth0      Link encap:Ethernet  HWaddr 00:50:8d:b0:ee:23  
          inet6 addr: fe80::250:8dff:feb0:ee23/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21239 errors:0 dropped:44 overruns:0 frame:0
          TX packets:44098 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2870997 (2.8 MB)  TX bytes:9702860 (9.7 MB)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:528 (528.0 B)  TX bytes:528 (528.0 B)

virbr0    Link encap:Ethernet  HWaddr 42:b8:6e:3a ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-10-05 02:38:24 -0500

jtaguinerd gravatar image

updated 2014-10-05 02:50:04 -0500

HI,

If your set up is multi-host dhcp, the compute node will act as the gateway of the VM. Make sure first that the compute node can access the internet. Additionally, the VM's gateway should be the IP address of the compute node. From inside the VM you can check this by route -n.

Also, I am wondering why you have assigned a public IP in your VM. It could also be setup in such a way that your instance will just get a fixed IP and then just attached a floating IP.

Another thing that might be usable is to add routing_source_ip in nova.conf

edit flag offensive delete link more
0

answered 2014-11-27 03:15:35 -0500

Rocky gravatar image

Hello,

I am also trying to deploy openstack with 2 node. When I am launching an instance at that time my compute network service goes down, i can't ping even controller node. Please do the needful.

Thanks - Ronak

edit flag offensive delete link more
0

answered 2014-10-13 21:04:02 -0500

gators gravatar image

add flat-interface = vnet0/ or whatever interface you got after you create an instance.

I don't think virbr0 is but if you don't see any other UP interface, try virbr0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-09-19 08:28:01 -0500

Seen: 978 times

Last updated: Oct 05 '14